Bug 1732722 - After login the KDE Plasma popup log of error about sssd-kcm
Summary: After login the KDE Plasma popup log of error about sssd-kcm
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: sssd
Version: 30
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Jakub Hrozek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-24 08:19 UTC by Everes
Modified: 2019-08-06 14:32 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-06 14:32:07 UTC


Attachments (Terms of Use)
System log (1.17 KB, text/plain)
2019-07-24 08:19 UTC, Everes
no flags Details

Description Everes 2019-07-24 08:19:43 UTC
Created attachment 1593066 [details]
System log

Description of problem:

After login the KDE popup the log of errors...

7/24/19 4:53 AM	systemd	sssd-kcm.socket: Failed with result 'service-start-limit-hit'.
7/24/19 4:53 AM	systemd	Failed to start SSSD Kerberos Cache Manager.
7/24/19 4:53 AM	systemd	sssd-kcm.service: Failed with result 'exit-code'.
7/24/19 4:53 AM	systemd	sssd-kcm.service: Start request repeated too quickly.
7/24/19 4:53 AM	kernel	audit: type=1131 audit(1563954817.715:276): pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=sssd-kcm comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=failed'
7/24/19 4:53 AM	audit	SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=sssd-kcm comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=failed'
7/24/19 4:53 AM	systemd	sssd-kcm.service: Failed with result 'exit-code'.
7/24/19 4:53 AM	systemd	sssd-kcm.service: Main process exited, code=exited, status=2/INVALIDARGUMENT
7/24/19 4:53 AM	sssd_kcm	(Wed Jul 24 04:53:37 2019) [sssd[kcm]] [server_setup] (0x0010): Error setting up logging (5) [Input/output error]
7/24/19 4:53 AM	sssd[kcm]	Could not open file [/var/log/sssd/sssd_kcm.log]. Error: [2][No such file or directory]

How reproducible: After login - KDE Plasma 5.15.5

Operating System: Fedora 30
KDE Plasma Version: 5.15.5
KDE Frameworks Version: 5.59.0
Qt Version: 5.12.4
Kernel Version: 5.1.18-300.fc30.x86_64
OS Type: 64-bit
Processors: 8 × Intel® Core™ i7-3770K CPU @ 3.50GHz
Memory: 7.7 GiB of RAM

Comment 1 Lukas Slebodnik 2019-07-24 08:41:45 UTC
(In reply to Everes from comment #0)

> 7/24/19 4:53 AM	systemd	sssd-kcm.service: Failed with result 'exit-code'.
> 7/24/19 4:53 AM	systemd	sssd-kcm.service: Main process exited, code=exited,
> status=2/INVALIDARGUMENT
> 7/24/19 4:53 AM	sssd_kcm	(Wed Jul 24 04:53:37 2019) [sssd[kcm]]
> [server_setup] (0x0010): Error setting up logging (5) [Input/output error]
> 7/24/19 4:53 AM	sssd[kcm]	Could not open file [/var/log/sssd/sssd_kcm.log].
> Error: [2][No such file or directory]
> 

Does the directory /var/log/sssd/ exist ?
Could you provide an output of commands?
   rpm -V sssd-common sssd-kcm
   rpm -q sssd-common sssd-kcm

Can you see some AVC denials?

Comment 2 Everes 2019-07-24 17:52:14 UTC
(In reply to Lukas Slebodnik from comment #1)
> (In reply to Everes from comment #0)
> 
> > 7/24/19 4:53 AM	systemd	sssd-kcm.service: Failed with result 'exit-code'.
> > 7/24/19 4:53 AM	systemd	sssd-kcm.service: Main process exited, code=exited,
> > status=2/INVALIDARGUMENT
> > 7/24/19 4:53 AM	sssd_kcm	(Wed Jul 24 04:53:37 2019) [sssd[kcm]]
> > [server_setup] (0x0010): Error setting up logging (5) [Input/output error]
> > 7/24/19 4:53 AM	sssd[kcm]	Could not open file [/var/log/sssd/sssd_kcm.log].
> > Error: [2][No such file or directory]
> > 
> 
> Does the directory /var/log/sssd/ exist ?
> Could you provide an output of commands?
>    rpm -V sssd-common sssd-kcm
>    rpm -q sssd-common sssd-kcm
> 
> Can you see some AVC denials?

- Does the directory /var/log/sssd/ exist ? 
R.: No.

- Can you see some AVC denials?
R.: No.

[tinker@localhost log]$ pwd
/var/log
[tinker@localhost log]$ cd sssd
bash: cd: sssd: No such file or directory
[tinker@localhost log]$ sudo rpm -V sssd-common sssd-kcm
missing     /var/log/sssd
[tinker@localhost log]$ sudo rpm -q sssd-common sssd-kcm
sssd-common-2.2.0-3.fc30.x86_64
sssd-kcm-2.2.0-3.fc30.x86_64
[tinker@localhost log]$

Comment 3 Lukas Slebodnik 2019-07-25 08:29:15 UTC
(In reply to Everes from comment #2)
> > Can you see some AVC denials?
> 
> - Does the directory /var/log/sssd/ exist ? 
> R.: No.
> 
> - Can you see some AVC denials?
> R.: No.
> 
> [tinker@localhost log]$ pwd
> /var/log
> [tinker@localhost log]$ cd sssd
> bash: cd: sssd: No such file or directory
> [tinker@localhost log]$ sudo rpm -V sssd-common sssd-kcm
> missing     /var/log/sssd

sssd does not create the file itself. I assume some script or you might accidently 
remove that directory.


Reinstalling the package sssd-common should create  missing  directory with correct owner, permissions and SELinux file context.

> [tinker@localhost log]$ sudo rpm -q sssd-common sssd-kcm
> sssd-common-2.2.0-3.fc30.x86_64
> sssd-kcm-2.2.0-3.fc30.x86_64
> [tinker@localhost log]$

Summary:  It is not a bug in sssd-kcm.

Comment 4 Lukas Slebodnik 2019-07-26 13:43:23 UTC
Are you fine with closing the bug?

Comment 5 Everes 2019-08-06 14:28:49 UTC
Yes. I thank your for solution.


Note You need to log in before you can comment on or make changes to this bug.