Bug 1732739 - Can't launch VNC console on vsphere 6
Summary: Can't launch VNC console on vsphere 6
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.11.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: 5.11.0
Assignee: Dávid Halász
QA Contact: Antonin Pagac
Red Hat CloudForms Documentation
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-24 09:04 UTC by Antonin Pagac
Modified: 2019-07-26 14:02 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-26 13:49:36 UTC
Category: Bug
Cloudforms Team: VMware
Target Upstream Version:


Attachments (Terms of Use)

Description Antonin Pagac 2019-07-24 09:04:25 UTC
Description of problem:
Can't launch VNC console on a VM running on vsphere 6. 

VNC console on this provider is supported and can be run on appliance version 5.10.

When trying on 5.11.0.15, this message is displayed:

"The appliance has no access to the assets required to run the WebMKS console. For more info please see the documentation."

Workaround is to have appliance version 5.10 and launch VNC console from there. Once this is done, the VNC console starts to work on this VM also on appliance version 5.11.

Version-Release number of selected component (if applicable):
5.11.0.15

How reproducible:
Always

Steps to Reproduce:
1. Have vsphere 6 provider added and testing VM created
2. Navigate to the VM and try to launch console by Access -> VM Console
3.

Actual results:
WebMKS warning displayed

Expected results:
VNC console launched

Additional info:

Comment 2 Dávid Halász 2019-07-24 14:29:42 UTC
This is not actually a bug as we no longer distinguish remote console types as we did it before. There's a HTML5-based remote console and the right protocol gets selected for the given VM's settings. In this case the VNC console wasn't enabled in vSphere for your VM so it selected the WebMKS type which is always available by default. However, you were missing the assets for WebMKS so you got the error message.

Previous versions of CF had a global setting for the VMware console type (VNC, WebMKS, VMRC) and if you selected VNC, it force-enabled the VNC in some cases. However, newer versions of vSphere no longer support the VNC protocol. Therefore, even if you force-enable the VNC support, the console won't work. This is why your workaround works, but with older versions only.

Unfortunately, we can no longer force-enable the VNC support and if it has not been enabled (through the vSphere UI or maybe automate) we are stuck with WebMKS. The problem is that there's no way to determine from the VMware API that the VNC can be force-enabled or not.

The right workaround is to upload the WebMKS assets...

Comment 3 Antonin Pagac 2019-07-24 14:41:14 UTC
Hi David,

thank you for this explanation. Detailed info on this can be found in bz 1547251 I believe.

With the lost ability to force VNC support, I believe this is working as designed and therefore is NOTABUG.


Note You need to log in before you can comment on or make changes to this bug.