Bug 1732766 - fence_aliyun: add RAM role functionality (RHEL8)
Summary: fence_aliyun: add RAM role functionality (RHEL8)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: fence-agents
Version: 8.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.2
Assignee: Oyvind Albrigtsen
QA Contact: Brandon Perkins
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-24 10:11 UTC by Oyvind Albrigtsen
Modified: 2020-04-28 15:30 UTC (History)
3 users (show)

Fixed In Version: fence-agents-4.2.1-31.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-04-28 15:30:15 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github ClusterLabs fence-agents pull 279 0 None closed Update fence_aliyun.py 2020-04-22 18:52:11 UTC
Github ClusterLabs fence-agents pull 286 0 None closed fence_aliyun: import EcsRamRoleCredential 2020-04-22 18:52:11 UTC
Red Hat Product Errata RHBA-2020:1580 0 None None None 2020-04-28 15:30:36 UTC

Description Oyvind Albrigtsen 2019-07-24 10:11:50 UTC
Description of problem:
Add RAM role functionality to fence_aliyun, which can be used instead of Access Key ID/Secret.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Oyvind Albrigtsen 2019-08-20 09:57:10 UTC
Additional patch.

Comment 12 errata-xmlrpc 2020-04-28 15:30:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1580


Note You need to log in before you can comment on or make changes to this bug.