Bug 1732773 - fence_vmware_rest: fix KeyError issue for suspended VMs (RHEL8)
Summary: fence_vmware_rest: fix KeyError issue for suspended VMs (RHEL8)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: fence-agents
Version: 8.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.1
Assignee: Oyvind Albrigtsen
QA Contact: cluster-qe@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-24 10:29 UTC by Oyvind Albrigtsen
Modified: 2019-11-05 20:42 UTC (History)
2 users (show)

Fixed In Version: fence-agents-4.2.1-29.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-05 20:42:13 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github ClusterLabs fence-agents pull 277 None None None 2019-07-24 10:29:14 UTC
Red Hat Product Errata RHBA-2019:3326 None None None 2019-11-05 20:42:16 UTC

Description Oyvind Albrigtsen 2019-07-24 10:29:15 UTC
Description of problem:
fence_vmware_rest fails with KeyError if VM is suspended.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 4 errata-xmlrpc 2019-11-05 20:42:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3326


Note You need to log in before you can comment on or make changes to this bug.