Bug 17328 - Pine expects looks for /bin/passwd to change passwords.
Summary: Pine expects looks for /bin/passwd to change passwords.
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: pine   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-09-07 17:11 UTC by Andy Wang
Modified: 2007-04-18 16:28 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-07 19:41:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andy Wang 2000-09-07 17:11:17 UTC
It looks like pine is expecting /bin/passwd when you use it to change your
system password.  This will not work as /bin/passwd does not exist by
default.   Of course, a simple link (or telling people not to use that
feature) is a nice workaround but I thought this should be mentioned.

Comment 1 Trond Eivind Glomsrxd 2000-09-07 19:34:44 UTC
Using pine to change your system password? Exactly how do provoke this error?

Comment 2 Andy Wang 2000-09-07 19:41:24 UTC
After starting up pine, choose SETUP from the Main Menu.  After choosing SETUP,
you can select from the sub-menu at the bottom of the screen.  Choose 'N' for
Newpassword and it attempts to execute /bin/passwd to change your unix
password.  I didn't know about this feature til a user brought it up.  Doesn't
seem like a good place to change your password, but I guess for the shell
clueless, it'd work.

Comment 3 Trond Eivind Glomsrxd 2000-09-07 20:28:01 UTC
Thanks. Fixed in pine-4.21-24... I wouldn't recommend it as a password changing
program, though ;).


Note You need to log in before you can comment on or make changes to this bug.