Bug 1732874 - USB device from hosts does not get detected in Windows 10 VM while it works on Linux
Summary: USB device from hosts does not get detected in Windows 10 VM while it works o...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: General
Version: 4.3.5
Hardware: x86_64
OS: All
unspecified
urgent vote
Target Milestone: ---
: ---
Assignee: bugs@ovirt.org
QA Contact: Lukas Svaty
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-24 15:03 UTC by Navneet Kumar Dubey
Modified: 2019-07-25 07:45 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-25 07:45:18 UTC
oVirt Team: Virt


Attachments (Terms of Use)

Description Navneet Kumar Dubey 2019-07-24 15:03:49 UTC
Description of problem: We have tried adding the USB device connected to the host to discover it on the guest . IN case of the RHEL guest it gets detected while for the Windows 10  we are not bale to discover it 


Version-Release number of selected component (if applicable):

Version of the ovirt-manager :4.3.5.3-1.el7
Version of the host : 
ovirt-host-4.3.1-0.0.master.20190115090506.gitc8ad67d.el7.x86_64
ovirt-release-master-4.4.0-0.2.master.20190723000137.gitea53f6e.el7.noarch
vdsm-4.30.8-9.gitf28e377.el7.x86_64
vdsm-hook-hostusb-4.20.2-1.el7.noarch


How reproducible:


Steps to Reproduce:
1. Installed vdsm-hook-hostusb and then configured the manager node with engine-config -s "UserDefinedVMProperties=hostusb=^0x[0-9a-fA-F]{4}:0x[0-9a-fA-F]{4}$". Restarted the engine services 
2.Add a custom key, select hostusb and enter the key. The format must be 0xHHHH:0xHHHH.
3. Additionally I also added host device to the VM as "usb devices" 
4. Additionally for Windows I enabled USB support by editing the VM

Actual results: The USB got detected in Linux but not in Windows 10 VM


Expected results: USB should have been detected in Windows 10


Additional info: Please let me know if I am wrong with the steps and if you can provide the actual doc or steps for configuring USB passthrough. 

Note : We are in teh stage of migrating our server from Vmware to Ovirt/RHEV. This feature has been of utmost importance for our telecom application as it ony runs on Physical PC and Vmware based client nodes. So I would request to check this on priority . Thank you

Comment 1 Ryan Barry 2019-07-25 01:33:09 UTC
lsusb would be useful

Some devices use a multiple stage initialization, and identifying the actual device will help check

Note that since 4.0, vdsm-hook-hostusb is not needed, and should not be used. Does this work without it?

Comment 2 Navneet Kumar Dubey 2019-07-25 04:42:03 UTC
[root@localhost ~]# lsusb
Bus 002 Device 002: ID 8087:8002 Intel Corp.
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 007: ID 04e8:6889 Samsung Electronics Co., Ltd GT-B3730 Composite LTE device (Commercial)
Bus 001 Device 004: ID 046b:ff10 American Megatrends, Inc. Virtual Keyboard and Mouse
Bus 001 Device 003: ID 046b:ff01 American Megatrends, Inc.
Bus 001 Device 002: ID 8087:800a Intel Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


04e8:6889 Samsung Electronics is the USB that I am referring. 

I have uninstalled the  vdsm-hook-hostusb and then tried but no luck. Could you please share the correct procedure to have this enabled . 

Also, I would like to know if we can work on this  Service request  in my time zone so the we can exchange more upadates and can close the issues

I am working in Indian Standard time zone  (GMT +5:30 )

Comment 3 Ryan Barry 2019-07-25 05:21:51 UTC
Bugzilla is kind of asynchronous by nature. Mailing lists (users@ovirt.org) and IRC (oftc/#ovirt) may get a more immediate response

Is it present in the device tree in Windows?

If redirection from a SPICE console is what you want, please ensure that the guest tools (and usbdk) are installed.

If you want it there all the time, was the device selected under host devices in the engine? If so, screenshot of the settings?

Comment 4 Navneet Kumar Dubey 2019-07-25 05:59:27 UTC
Hi Ryan, 

Super, I had just installed usbdk and not the guest tools . Now When i installed the guest tool and rebooted I am able to see the Device. 

Thank you so much for following up with me on priority and helping me out. THis was blocker for us and now e can go forward to implement it in our infra. 

As Always Red Hat been the champion in the Industry. Thanks a lot. You can mark the bug as closed.

Comment 5 Navneet Kumar Dubey 2019-07-25 07:41:35 UTC
One more query before we go closing the case. I see some of the host nodes are having the option of "hostusb" under the edit options of Custom Properties When we list the keys from the dropdown. Could you please let me know what can be the reason behind it . 

The Windows VM wheere its working now is hosted on the hypervisor node where no such options are listed as "hostusb" under the edit options of Custom Properties

Comment 6 Michal Skrivanek 2019-07-25 07:45:18 UTC
that's from the time when you tried to use the hostusb hook. you can reverse the steps you did when you installed it (modify UserDefinedVMProperties). 
It's harmless anyway


Note You need to log in before you can comment on or make changes to this bug.