Bug 173291 - After unclean shutdown, module options for ipw2100 driver are ignored
After unclean shutdown, module options for ipw2100 driver are ignored
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: hotplug (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-15 18:28 EST by Andre Srinivasan
Modified: 2014-03-16 22:56 EDT (History)
1 user (show)

See Also:
Fixed In Version: FC5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-25 15:11:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andre Srinivasan 2005-11-15 18:28:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Description of problem:
If I have an unclean shutdown, on boot I noticed that even though I have specified that the ipw2100 driver module get loaded disabled in modprobe.conf, the driver gets loaded and the radio is enabled.  The expected behavior (of the driver getting loaded and the radio staying disabled during boot) occurs if I have a clean shutdown.

Version-Release number of selected component (if applicable):
2.6.14-1.1637_FC4

How reproducible:
Always

Steps to Reproduce:
1. Configure options to disable the radio on ipw2100 in modprobe.conf
2. Kill power to the box
3. Boot the box.  You'll see the driver module get loaded with the radio enabled.
  

Actual Results:  The driver ignores the options in modprobe.conf

Expected Results:  The option to disable the radio should have been respected.

Additional info:
Comment 1 Bill Nottingham 2005-11-16 12:25:01 EST
This only happens on unclean shutdown?
Comment 2 Andre Srinivasan 2005-11-16 12:33:25 EST
This only happens (and happens every time) on startup after an unclean shutdown.
Comment 3 Bill Nottingham 2005-11-16 12:39:40 EST
What's the exact line you have in modprobe.conf?
Comment 4 Andre Srinivasan 2005-11-16 13:15:24 EST
options ipw2100 disable=1
Comment 5 Bill Nottingham 2006-09-25 14:46:25 EDT
Does this persist in FC5? I was unable to reproduce this.
Comment 6 Andre Srinivasan 2006-09-25 14:50:20 EDT
(In reply to comment #5)
> Does this persist in FC5? I was unable to reproduce this.

No, this no longer occurs in FC5.

Thanks.
-andre.
Comment 7 Bill Nottingham 2006-09-25 15:11:48 EDT
Closing, then.

Note You need to log in before you can comment on or make changes to this bug.