Bug 1732946 - memory leak?
Summary: memory leak?
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: geoclue2
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Zeeshan Ali
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-24 19:50 UTC by Vincent Batts
Modified: 2020-01-05 01:56 UTC (History)
3 users (show)

Fixed In Version: geoclue2-2.5.4-1.fc31 geoclue2-2.5.5-1.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-01 00:01:11 UTC
zeenix: needinfo-


Attachments (Terms of Use)

Description Vincent Batts 2019-07-24 19:50:28 UTC
Description of problem:
geoclue is top'ing the chart of memory usage on my laptop

Version-Release number of selected component (if applicable):
geoclue2-2.5.3-1.fc30.x86_64

How reproducible:
no idea. just noticing it

Steps to Reproduce:
1. leave desktop running for a number of days
2.
3.

Actual results:
(from `top`)
 1925 geoclue   20   0 1680336 601252  13556 S   1.7   1.8 175:13.45 geoclue                                                                                                                                   

That's 601Mb of RSS usage. Topping the chart above even firefox and `gnome-software`

Expected results:
something like a geo informant to not use but a few Mb of rss

Additional info:
```shell
$ ps -o etime 1925
    ELAPSED
 8-02:16:14
```
so, running for ~ 8 days, 2hrs

Comment 1 Zeeshan Ali 2019-07-25 10:59:09 UTC
Someone filed an issue upstream: https://gitlab.freedesktop.org/geoclue/geoclue/issues/120 . Is is the same? I-e does this happen if you're offline only?

Comment 2 Zeeshan Ali 2019-09-27 11:43:23 UTC
Fixed upstream.

Comment 3 Fedora Update System 2019-09-27 18:25:07 UTC
FEDORA-2019-fd464c6ab0 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-fd464c6ab0

Comment 4 Fedora Update System 2019-09-27 18:25:07 UTC
FEDORA-2019-01202356f8 has been submitted as an update to Fedora 31. https://bodhi.fedoraproject.org/updates/FEDORA-2019-01202356f8

Comment 5 Fedora Update System 2019-09-28 00:53:40 UTC
geoclue2-2.5.4-1.fc31 has been pushed to the Fedora 31 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-01202356f8

Comment 6 Fedora Update System 2019-09-28 01:21:13 UTC
geoclue2-2.5.4-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-fd464c6ab0

Comment 7 Fedora Update System 2019-09-30 18:44:48 UTC
FEDORA-2019-edd14d9101 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-edd14d9101

Comment 8 Fedora Update System 2019-10-01 00:01:11 UTC
geoclue2-2.5.4-1.fc31 has been pushed to the Fedora 31 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2019-10-01 01:01:52 UTC
geoclue2-2.5.5-1.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-edd14d9101

Comment 10 Fedora Update System 2019-10-15 22:39:22 UTC
geoclue2-2.5.5-1.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Reid Rivenburgh 2020-01-05 01:56:46 UTC
I'm using:

geoclue2-2.5.5-1.fc31.x86_64

and I'm still seeing really high memory usage.  I just had to kill it because it looked like it was using gigabytes of memory and causing my system to swap out of control.  Let me know if there's something I can do to help....


Note You need to log in before you can comment on or make changes to this bug.