Bug 1732987 - [Docs] RHOSP 15 All-in-one installation guide has not been updated
Summary: [Docs] RHOSP 15 All-in-one installation guide has not been updated
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation
Version: 15.0 (Stein)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Alex McLeod
QA Contact: RHOS Documentation Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-24 22:00 UTC by Luke Short
Modified: 2019-07-25 16:03 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-25 16:03:36 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Luke Short 2019-07-24 22:00:05 UTC
Description of problem:
The RHOSP 15 all-in-one installation for the python3-tripleoclient is a direct copy of the RHOSP 14 all-in-one installation. The repositories and package name need to be updated.

Version-Release number of selected component (if applicable):
RHOSP 15 Beta

How reproducible:
100%

Steps to Reproduce:
Compare the instructions for installing python3-tripleoclient for a normal deployment [1] and the all-in-one [2].

1. https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/15-beta/html-single/director_installation_and_usage/index?lb_target=stage#preparing-the-undercloud
2. https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/15-beta/html/quick_start_guide/installing-the-all-in-one-openstack-environment

Actual results:
The document is currently a direct copy from RHOSP 14. That no longer applies because (A) the repositories are named differently and after RHEL 8 and (B) the package should now be python3-tripleoclient (python-tripleoclient does not work because no Python 2 package is provided).

Expected results:
The end-user should have the steps to install RHOSP 15; not RHOSP 14.

Additional info:
For consolidation and simplicity, we may want to link back to the original TripleO package installation steps in the all-in-one guide.

https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/15-beta/html-single/director_installation_and_usage/index?lb_target=stage#preparing-the-undercloud


Note You need to log in before you can comment on or make changes to this bug.