Bug 1733060 - The "Cancel" button doesn't take effect on rolebinding creation page
Summary: The "Cancel" button doesn't take effect on rolebinding creation page
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.2.0
Assignee: Steve Goodwin
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-25 06:55 UTC by Yanping Zhang
Modified: 2019-10-16 06:33 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:33:28 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 2151 None None None 2019-07-25 11:59:45 UTC
Red Hat Product Errata RHBA-2019:2922 None None None 2019-10-16 06:33:43 UTC

Description Yanping Zhang 2019-07-25 06:55:14 UTC
Description of problem:
When user creates rolebinding from "Administration"->"Role Bindings" page, there is no response if click "Cancel".

Version-Release number of selected component (if applicable):
4.2.0-0.nightly-2019-07-24-220922
console image: quay.io/openshift-release-dev/ocp-v4.0-art-dev@sha256:d2e7b52b23c5755d0aa8e47e848049c188400e575a8678e175bd03130f4c766c
https://github.com/openshift/console/commit/1c78f00ce5e2a313e4dd673df240e438438d45b6

How reproducible:
Always

Steps to Reproduce:
1.Open rolebinding creation page by clicking "Administration"->"Role Bindings"->"Create Binding".
2.Click "Cancel" button.
3.

Actual results:
2. There is no response.

Expected results:
2. Should return to rolebinding list page.

Additional info:

Comment 1 Steve Goodwin 2019-07-26 17:03:50 UTC
PR with fix
https://github.com/openshift/console/pull/2151

Comment 3 Yanping Zhang 2019-07-29 04:47:23 UTC
4.2.0-0.nightly-2019-07-28-222114
Checked on OCP 4.2 with above version. now after click the "Cancel" button on creating rolebinding page, it will return to the rolebinding list page.
The bug has been fixed.

Comment 4 errata-xmlrpc 2019-10-16 06:33:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.