Bug 173309 - Hexviewer does not display ASCII chars anymore
Summary: Hexviewer does not display ASCII chars anymore
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: mc (Show other bugs)
(Show other bugs)
Version: 4
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jindrich Novy
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-11-16 08:07 UTC by Enrico Scholz
Modified: 2013-07-02 23:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-16 13:57:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Enrico Scholz 2005-11-16 08:07:05 UTC
Description of problem:

The Hexviewer in the embedded viewer does not show the printable ASCII chars
anymore but prints only '.'.


Version-Release number of selected component (if applicable):

mc-4.6.1a-0.14.FC4


How reproducible:

100%


Steps to Reproduce:
0. open an xterm
1. 'mc'
2. move to a file and F3
3. press F4
  
Actual results:

In the right column, only '.' are displayed


Expected results:

Right column shows printable chars and replaces only the non-printable ones by '.'


Additional info:

LANG=de_DE.UTF-8
LC_COLLATE=C

Comment 1 Jindrich Novy 2005-11-16 13:57:10 UTC
Ok, it was caused by a bug in the UTF-8 patch. The original code tried to
display the UTF-8 characters even in the hexviewing/editing mode, what's pretty
odd. I removed this ill-designed feature to display the characters correctly.

Comment 2 Fedora Update System 2005-11-16 18:50:29 UTC
From User-Agent: XML-RPC

mc-4.6.1a-0.15.FC4 has been pushed for FC4, which should resolve this issue.  If these problems are still present in this version, then please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.