Bug 1733116 - Operator local-storage does not exist in OperatorHub.
Summary: Operator local-storage does not exist in OperatorHub.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Release
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.2.0
Assignee: Luke Meyer
QA Contact: Qin Ping
URL:
Whiteboard:
: 1740504 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-25 09:06 UTC by Liang Xia
Modified: 2019-10-16 06:33 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:33:28 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2922 None None None 2019-10-16 06:33:43 UTC

Description Liang Xia 2019-07-25 09:06:33 UTC
Description of problem:
Operator local-storage does not exist in OperatorHub.


Version-Release number of selected component (if applicable):
4.2.0-0.nightly-2019-07-21-222447


How reproducible:
Always


Steps to Reproduce:
1. Set up 4.2 cluster.
2. Login into web console as kubeadmin and check OperatorHub.


Actual results:
Operator local-storage does not exist in OperatorHub.


Expected results:
Operator local-storage exist in OperatorHub and can be installed.


Additional info:

Comment 1 Hemant Kumar 2019-07-25 15:46:45 UTC
I believe storage team has done all that was needed to be done to make the operator available in the OperatorHub. From my conversation with Luke - I gathered that they haven't yet started pushing new operators into 4.2 builds yet. I am going to move this BZ over to them since there is nothing that needs to be done from storage side.

Comment 2 Jian Zhang 2019-08-01 10:23:40 UTC
Hi, Hemant

Thanks for your report! Per comment 1, move on it to ART team since it's not an OLM bug. Correct me if I'm wrong.

Comment 3 Luke Meyer 2019-08-01 19:57:43 UTC
Right, we don't have operator metadata handled for 4.2 yet :(

Comment 4 Hemant Kumar 2019-08-13 14:40:34 UTC
*** Bug 1740504 has been marked as a duplicate of this bug. ***

Comment 5 Liang Xia 2019-08-14 02:06:12 UTC
This is blocking partial of local volume testing. E.g, as stated in https://bugzilla.redhat.com/show_bug.cgi?id=1740504, if there are issues in the images, we may not have enough time to fix/rebuild/test the new images.

Comment 12 errata-xmlrpc 2019-10-16 06:33:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.