Bug 173314 - HTTP Proxy password shown in clear text
HTTP Proxy password shown in clear text
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
400
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike McCune
Vlady Zlatkin
:
: 144384 (view as bug list)
Depends On:
Blocks: 178198 203352
  Show dependency treegraph
 
Reported: 2005-11-16 04:25 EST by Matthew Booth
Modified: 2007-07-31 11:29 EDT (History)
3 users (show)

See Also:
Fixed In Version: rhn406
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-15 14:44:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Booth 2005-11-16 04:25:40 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.12) Gecko/20050921 Red Hat/1.0.7-1.4.1 Firefox/1.0.7

Description of problem:
Go to Satellite Tools -> Satellite Configuration. The "HTTP proxy password" is shown in clear text. As this is a password it should use <input type="password">. There should probably also be 2 of them.

Version-Release number of selected component (if applicable):
rhn401

How reproducible:
Always

Steps to Reproduce:
1. Go to Satellite Tools -> Satellite Configuration

Actual Results:  Joe User standing near administrator views proxy details and goes on pr0n downloading spree safe in the knowledge that he's not using his own login details.  Sexual harassment lawsuits against all our large corporate customers, and the moral collapse of society.

Expected Results:  ********

Additional info:
Comment 1 Matthew Booth 2005-11-16 04:44:16 EST
Also, it would be useful to be able to leave authentication details blank.
satellite-sync should prompt for them interactively if required.
Comment 4 Mike McCune 2006-01-26 11:50:14 EST
*** Bug 144384 has been marked as a duplicate of this bug. ***
Comment 6 Mike McCune 2006-02-06 15:10:57 EST
TESTPLAN:

1) Nav to Satellite Tools -> Satellite Configuration
2) verify that the HTTP Proxy Password field shows ***** when you  type
   in a password.
3) submit form.  verify that it still shows *****
Comment 7 Vlady Zlatkin 2006-02-15 18:38:32 EST
works
Comment 8 Vlady Zlatkin 2006-03-03 18:10:31 EST
verified in stage, and verified content of satellite to match previously blessed
content
Comment 9 Todd Warner 2006-03-15 14:44:02 EST
Closing upon release of RHN 406

Note You need to log in before you can comment on or make changes to this bug.