Bug 1733197 - Trunk subports sometimes not becoming ACTIVE and trunk:subport
Summary: Trunk subports sometimes not becoming ACTIVE and trunk:subport
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron
Version: 14.0 (Rocky)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: z4
: 14.0 (Rocky)
Assignee: Slawek Kaplonski
QA Contact: Eran Kuris
URL:
Whiteboard:
Depends On:
Blocks: 1736854
TreeView+ depends on / blocked
 
Reported: 2019-07-25 11:51 UTC by Michał Dulko
Modified: 2019-11-06 16:50 UTC (History)
7 users (show)

Fixed In Version: openstack-neutron-13.0.4-0.20190508213452.de95bc6.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1736854 (view as bug list)
Environment:
Last Closed: 2019-11-06 16:50:27 UTC
Target Upstream Version:


Attachments (Terms of Use)
openvswitch-agent.log (1.12 MB, text/plain)
2019-07-25 11:51 UTC, Michał Dulko
no flags Details
server.log (1.60 MB, text/plain)
2019-07-25 11:51 UTC, Michał Dulko
no flags Details


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 679053 'None' MERGED Increase number of retries in _process_trunk_subport_bindings 2020-02-14 20:30:42 UTC
Red Hat Product Errata RHBA-2019:3750 None None None 2019-11-06 16:50:55 UTC

Description Michał Dulko 2019-07-25 11:51:19 UTC
Created attachment 1593383 [details]
openvswitch-agent.log

Description of problem:
We're occasionally hitting a bug preventing Kuryr-Kubernetes from attaching ports to a trunk. The result of the operation on the API is 200, but ports never gets into ACTIVE and switches device_owner to trunk:subport. In our case Kuryr is creating those ports in bulks of 3, then tagging them one-by-one, then attaching to a trunk using random segmentation ID's.

Removing the subport from trunk and attaching it again resolves the issue.

In the logs of openvswitch-agent we see:

Remote error: StaleDataError UPDATE statement on table 'standardattributes' expected to update 1 row(s); 0 were matched.

Version-Release number of selected component (if applicable):
OSP14

How reproducible:
Occasionally. :(

Steps to Reproduce (I'm putting what Kuryr does):
1. Create 3 ports in bulk.
2. Tag them.
3. Add them to a trunk.

Actual results:
Sometimes port stays DOWN and still has what Kuryr put as device_owner instead of trunk:subport.

Expected results:
Port becomes ACTIVE and has trunk:subport as device_owner.

Additional info:
In the logs look for port 008a09d7-97a4-4aee-880c-c3dc5ad3d4f6, that's the affected one.

Comment 1 Michał Dulko 2019-07-25 11:51:58 UTC
Created attachment 1593384 [details]
server.log

Comment 7 Bob Fournier 2019-09-25 14:10:48 UTC
Slawek - I built neutron to pick up fix for https://bugzilla.redhat.com/show_bug.cgi?id=1717558 and in turn included fix here.  The package is openstack-neutron-13.0.4-0.20190508213452.de95bc6.el7ost.

Comment 8 Slawek Kaplonski 2019-09-25 14:57:49 UTC
Thx Bob for building package and for info about it :)

Comment 15 errata-xmlrpc 2019-11-06 16:50:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3750


Note You need to log in before you can comment on or make changes to this bug.