Bug 173321 - Package 'saslauthd' and 'dbconverter-2' in different packages
Package 'saslauthd' and 'dbconverter-2' in different packages
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cyrus-sasl (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-16 05:13 EST by Enrico Scholz
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.1.21-9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-19 16:39:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2005-11-16 05:13:33 EST
Description of problem:

'saslauthd' is a very useful daemon needed for a lot of use cases and does not
have many dependencies.

'dbconverter-2' is used in some corner cases only but has huge dependencies
(libmysqlclient.so.15 libpq.so.4).

Therefore, these programs should be in different packages so that people who
want only 'saslauthd', do not have to install the MySQL + PostgreSQL deps.



Version-Release number of selected component (if applicable):

cyrus-sasl-2.1.21-8
Comment 1 Nalin Dahyabhai 2005-11-16 10:48:18 EST
Hmm, actually, there's no reason I can see why dbconverter-2 should have those
dependencies, since it only accesses sasldb files directly (i.e., without going
through the auxprop APIs).
Comment 2 Enrico Scholz 2005-12-17 11:26:01 EST
Any chance to get this fixed in FC5 before we enter some freeze?

Note You need to log in before you can comment on or make changes to this bug.