Bug 1733244 - rsyslog TLS driver x509 certificate validation needs to check extendedUseKey field
Summary: rsyslog TLS driver x509 certificate validation needs to check extendedUseKey ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: rsyslog
Version: ---
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: rc
: 8.0
Assignee: Jiří Vymazal
QA Contact: Dalibor Pospíšil
URL:
Whiteboard:
Depends On:
Blocks: 1510124
TreeView+ depends on / blocked
 
Reported: 2019-07-25 13:58 UTC by Steve Grubb
Modified: 2019-12-02 15:49 UTC (History)
10 users (show)

Fixed In Version: rsyslog-8.37.0-13.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-05 20:56:05 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github rsyslog rsyslog pull 3845 'None' closed Stricter GnuTLS operation 2020-02-12 18:18:59 UTC
Red Hat Product Errata RHEA-2019:3371 None None None 2019-11-05 20:56:21 UTC

Description Steve Grubb 2019-07-25 13:58:06 UTC
Description of problem:
OSPP v4.2 certification requires that x509 certificates be carefully checked.

https://www.niap-ccevs.org/MMO/PP/-442-/#FIA_X509_EXT.1

The test is that a certificate is created that has code signing enabled but then installed so that the application tries to use it for TLS client or server. It should fail this check. To check the key purpose, it would have to use the call gnutls_certificate_verify_peers() and pass explicitly the purpose to check against (e.g.,GNUTLS_KP_TLS_WWW_SERVER).


Version-Release number of selected component (if applicable):
rsyslog-8.37.0-10.el8

Steps to Reproduce:
1. Create a x509 certificate with only code signing enabled
2. Install for TLS usage
3. Start the daemon

Also, a server certificate could be used on a client system or vice versa.

Actual results:
TLS connection works

Expected results:
Failed connection

Comment 34 errata-xmlrpc 2019-11-05 20:56:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:3371


Note You need to log in before you can comment on or make changes to this bug.