Bug 1733277 - Cockpit firewall fails to add custom port
Summary: Cockpit firewall fails to add custom port
Keywords:
Status: CLOSED DUPLICATE of bug 1721414
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: cockpit
Version: 8.1
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: rc
: 8.0
Assignee: Martin Pitt
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-25 15:05 UTC by Ricardo Gerardi
Modified: 2019-07-30 08:43 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-30 08:43:24 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
Image of the Cockpit screen with error message (28.52 KB, image/png)
2019-07-25 15:05 UTC, Ricardo Gerardi
no flags Details

Description Ricardo Gerardi 2019-07-25 15:05:10 UTC
Created attachment 1593433 [details]
Image of the Cockpit screen with error message

Description of problem:

When trying to add a custom port to firewalld using Cockpit interface, it fails with error:

Failed to add service
Error message: org.freedesktop.DBus.Error.InvalidArgs: Too few values in tuple/struct


Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux 8.1 Beta
cockpit-system-196-1.el8.noarch


How reproducible:
Always


Steps to Reproduce:
1.Access Cockpit interface using an user with root privileges
2.Navigate to Networking->Firewall->Add Services->Custom Port
3.Input TCP port number, for example, 3000 or 8080. Click "Add Ports"

Actual results:
Error message:
Failed to add service
Error message: org.freedesktop.DBus.Error.InvalidArgs: Too few values in tuple/struct


Expected results:
TCP Port would be successfully added to the firewall rules


Additional info:

Comment 1 Martin Pitt 2019-07-30 08:43:24 UTC
This was due to an API break in firewalld, marking as duplicate.

*** This bug has been marked as a duplicate of bug 1721414 ***


Note You need to log in before you can comment on or make changes to this bug.