Bug 1733315 - If resources for NFD are present on the cluster, the operator should update all resources that belong to NFD.
Summary: If resources for NFD are present on the cluster, the operator should update a...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node Feature Discovery Operator
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.2.0
Assignee: Zvonko Kosic
QA Contact: Walid A.
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-25 16:36 UTC by Zvonko Kosic
Modified: 2019-10-16 06:33 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:33:28 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift cluster-nfd-operator pull 19 'None' closed Bug 1733315: Various fixies for Updates of Resources already in the Cluster 2020-02-19 19:34:19 UTC
Red Hat Product Errata RHBA-2019:2922 None None None 2019-10-16 06:33:43 UTC

Description Zvonko Kosic 2019-07-25 16:36:12 UTC
Description of problem:
If resources for NFD are present on the cluster, the operator should update all resources that belong to NFD.


Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. Deploy some of the assets the operator manages 
2. Deploy the operator and watch the logs for Update messages
3.

Actual results:
Not all resources are updated.


Expected results:
All resources are updated. 


Additional info:

Comment 1 Zvonko Kosic 2019-07-25 16:45:20 UTC
Do not update service account as it leads to accumulating secrets; see BZ1714484

Comment 2 Zvonko Kosic 2019-07-26 14:33:10 UTC
This fixes the issues described: https://github.com/openshift/cluster-nfd-operator/pull/19

Comment 7 errata-xmlrpc 2019-10-16 06:33:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.