Bug 1733416 - Cockpit UI dropdown menu changes needed for single node
Summary: Cockpit UI dropdown menu changes needed for single node
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: cockpit-ovirt
Classification: oVirt
Component: gluster-ansible
Version: 0.13.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ovirt-4.4.0
: 0.14.1
Assignee: Parth Dhanjal
QA Contact: SATHEESARAN
URL:
Whiteboard:
Depends On:
Blocks: 1733413
TreeView+ depends on / blocked
 
Reported: 2019-07-26 03:53 UTC by bipin
Modified: 2020-05-20 20:00 UTC (History)
6 users (show)

Fixed In Version: cockpit-ovirt-0.14.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1733413
Environment:
Last Closed: 2020-05-20 20:00:57 UTC
oVirt Team: Gluster
sbonazzo: ovirt-4.4?


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 104055 0 master MERGED Disable dropdowns when unneccesary 2020-04-08 09:05:55 UTC

Description bipin 2019-07-26 03:53:46 UTC
+++ This bug was initially created as a clone of Bug #1733413 +++

Description of problem:
=======================
Few Minor UI changes needed for single node

1. In Single node deployment Volumes tab, the volume type is displayed with a dropdown box, since the only volume supported is distributed there is no need for a dropdown.

2. Same in case of Bricks tab, Select Host is displayed with a dropdown.


Version-Release number of selected component (if applicable):
============================================================


How reproducible:
=================

Steps to Reproduce:
==================
1.
2.
3.

Actual results:
==============


Expected results:
================


Additional info:
===============

--- Additional comment from bipin on 2019-07-26 03:49 UTC ---



--- Additional comment from bipin on 2019-07-26 03:51:13 UTC ---

Under bricks tab, the info "Arbiter bricks will be created on the third host in the host list" can be removed.
Screenshot attached above

Comment 1 Sandro Bonazzola 2020-01-23 12:16:53 UTC
All referenced patches have been merged, can this bug move to modified?
A build including referenced patches have been issued, can this move to ON_QA?

Comment 3 SATHEESARAN 2020-03-30 14:12:57 UTC
Verified with cockpit-ovirt-dashboard-0.14.3

With 3 node HC deployment started from cockpit wizard,
the volume type is fixed as 'replicate'

With single node deployment started from cockpit wizard,
the volume type is fixed as 'distribute'

Comment 4 Sandro Bonazzola 2020-05-20 20:00:57 UTC
This bugzilla is included in oVirt 4.4.0 release, published on May 20th 2020.

Since the problem described in this bug report should be
resolved in oVirt 4.4.0 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.