Bug 1733419 - The s.st_size > (6144LL * MB) error in the ldb_lmdb_size_test.c file shows that the ldb database cannot meet the test size.
Summary: The s.st_size > (6144LL * MB) error in the ldb_lmdb_size_test.c file shows th...
Keywords:
Status: CLOSED DUPLICATE of bug 1794349
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libldb
Version: 7.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Isaac Boukris
QA Contact: sssd-qe
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-26 03:55 UTC by wangye
Modified: 2020-02-05 08:57 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-02-05 08:57:29 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description wangye 2019-07-26 03:55:23 UTC
Description of problem:
The s.st_size > (6144LL * MB) error in the ldb_lmdb_size_test.c file shows that the ldb database cannot meet the test size.

Version-Release number of selected component (if applicable):
The latest version also exists

How reproducible:
Make a compilation in ldb, then run ldb_lmdb_size_test directly under /bin/default

Steps to Reproduce:
1.Download ldb source package
2.Compile code with make
3.Run ldb_lmdb_size_test in the /bin/default directory.

Actual results:
[root@localhost default]# ./ldb_lmdb_size_test
[==========] Running 1 test(s).
[ RUN      ] test_db_size_gt_4GB
[  ERROR   ] --- s.st_size > (6144LL * MB)
[   LINE   ] --- ../tests/ldb_lmdb_size_test.c:199: error: Failure!
[  FAILED  ] test_db_size_gt_4GB
[==========] 1 test(s) run.
[  PASSED  ] 0 test(s).
[  FAILED  ] 1 test(s), listed below:
[  FAILED  ] test_db_size_gt_4GB

 1 FAILED TEST(S)


Expected results:

No error, code test can normally check a larger than 4G database size
Additional info:
I suspect that the apitest.ldb file in the code failed to be created. The size does not exceed 4G, but it cannot be modified. Block it.

Comment 2 Isaac Boukris 2019-12-17 09:39:53 UTC
The test pass on my machine:
[ldb]$ ./bin/ldb_lmdb_size_test
[==========] Running 1 test(s).
[ RUN      ] test_db_size_gt_4GB
[       OK ] test_db_size_gt_4GB
[==========] 1 test(s) run.
[  PASSED  ] 1 test(s).

Can you tell more about the rhel version, samba/ldb version, machine arch, hardware specifications and a detailed description how to reproduce ?

Comment 3 Isaac Boukris 2020-02-05 08:57:29 UTC
My mistake, i tested upstream with lmdb support, but in rhel we do not yet supported lmdb as per #1794349 so 4g is the limit, closing as duplicate.

*** This bug has been marked as a duplicate of bug 1794349 ***


Note You need to log in before you can comment on or make changes to this bug.