Bug 1733422 - Redeploying Certificates with redeploy-certificates.yml was failed on OCP 3.11.129
Summary: Redeploying Certificates with redeploy-certificates.yml was failed on OCP 3.1...
Keywords:
Status: CLOSED DUPLICATE of bug 1733327
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Russell Teague
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-26 04:13 UTC by Hiroyuki Kaneko
Modified: 2019-08-28 19:46 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-23 03:13:57 UTC
Target Upstream Version:


Attachments (Terms of Use)
pod error log (1.95 KB, text/plain)
2019-07-26 04:15 UTC, Hiroyuki Kaneko
no flags Details
Ansible Debug Log (2.97 MB, text/plain)
2019-07-26 04:16 UTC, Hiroyuki Kaneko
no flags Details
Ansible Inventory file (12.82 KB, text/plain)
2019-07-29 06:39 UTC, Hiroyuki Kaneko
no flags Details

Description Hiroyuki Kaneko 2019-07-26 04:13:18 UTC
Description of problem:

I am facing the issue that failed redeploying certificates with playbook/redeploy-certificate.yml during redeploying certificates for service catalog.

Failed Task in the playbook is 'TASK [openshift_service_catalog : Verify that the controller-manager is running]' because that controller manager was not ready. 
The reason the pod was not ready seems to be as follows:

controller_manager.go:237] error running controllers: failed to get api versions from server: failed to get supported resources from server: unable to retrieve the complete list of server APIs: metrics.k8s.io/v1beta1: Unauthorized

Please find out the attached logs. 

Version-Release number of selected component (if applicable):

oc v3.11.129
kubernetes v1.11.0+d4cacc0
openshift-ansible-3.11.129-1.git.0.11838de.el7.noarch

How reproducible:
always

Steps to Reproduce:
1. Inatall OpenShift 3.11 with Ansible playbook
2. Execute ansible playbook 'playbook/redeplloy-certificate.yaml'

Actual results:
Failed to redeploy service catalog certificates.

Expected results:
Succeed to redeploy certificates.

Additional info:

Comment 1 Hiroyuki Kaneko 2019-07-26 04:15:23 UTC
Created attachment 1593553 [details]
pod error log

Comment 2 Hiroyuki Kaneko 2019-07-26 04:16:06 UTC
Created attachment 1593554 [details]
Ansible Debug Log

Comment 3 Hiroyuki Kaneko 2019-07-29 06:39:36 UTC
Created attachment 1594155 [details]
Ansible Inventory file

Comment 4 Jesus M. Rodriguez 2019-08-23 03:13:57 UTC

*** This bug has been marked as a duplicate of bug 1733327 ***


Note You need to log in before you can comment on or make changes to this bug.