Bug 1733431 - About page does not work for normal user
Summary: About page does not work for normal user
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.2.0
Assignee: Jakub Hadvig
QA Contact: Yadan Pei
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-26 05:32 UTC by shahan
Modified: 2019-10-16 06:33 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:33:49 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 2181 None None None 2019-07-26 17:10:50 UTC
Red Hat Product Errata RHBA-2019:2922 None None None 2019-10-16 06:33:59 UTC

Description shahan 2019-07-26 05:32:28 UTC
Description of problem:
 About page does not work for normal user

Version-Release number of selected component (if applicable):
4.2.0-0.nightly-2019-07-24-220922

How reproducible:
Always

Steps to Reproduce:
1. check about page with normal user
2.
3.

Actual results:
It will direct to blank page
vendors~main-chunk-2aa8072d6ce9144c3578.min.js:152 TypeError: Cannot read property 'data' of undefined
    at S (role.jsx:13)
    at $i (vendors~main-chunk-2aa8072d6ce9144c3578.min.js:152)
    at Da (vendors~main-chunk-2aa8072d6ce9144c3578.min.js:152)
    at Wo (vendors~main-chunk-2aa8072d6ce9144c3578.min.js:152)
    at Yo (vendors~main-chunk-2aa8072d6ce9144c3578.min.js:152)
    at ks (vendors~main-chunk-2aa8072d6ce9144c3578.min.js:152)
    at Ps (vendors~main-chunk-2aa8072d6ce9144c3578.min.js:152)
    at Is (vendors~main-chunk-2aa8072d6ce9144c3578.min.js:152)
    at Tn (vendors~main-chunk-2aa8072d6ce9144c3578.min.js:152)
fo @ vendors~main-chunk-2aa8072d6ce9144c3578.min.js:152


Expected results:
Should work well for normal user

Additional info:

Comment 1 Jakub Hadvig 2019-07-26 17:03:48 UTC
Fixinf PR: https://github.com/openshift/console/pull/2181

Comment 3 shahan 2019-07-29 06:12:11 UTC
About page works well for normal user now. Verified this bug.
4.2.0-0.nightly-2019-07-28-222114

Comment 4 errata-xmlrpc 2019-10-16 06:33:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.