Bug 1733567 - The API documentation has incorrect data for set_current_group on a user.
Summary: The API documentation has incorrect data for set_current_group on a user.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: API
Version: 5.11.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: GA
: cfme-future
Assignee: Joe Vlcek
QA Contact: Sudhir Mallamprabhakara
Red Hat CloudForms Documentation
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-26 14:40 UTC by Joe Vlcek
Modified: 2019-07-26 17:58 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-26 17:58:57 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description Joe Vlcek 2019-07-26 14:40:11 UTC
Description of problem:

The API documentation has incorrect data for set_current_group on a user.

The current, incorrect, data is:

{
  "action" : "set_current_group",
  "resource" : {
    "group" : { "description" : "EvmGroup-auditor" }
  }
}

The correct data should be:

{
  "action" : "set_current_group",
  "resource" : {
    "group" : { "id" : "12" }
  }
}

Comment 3 Joe Vlcek 2019-07-26 17:58:57 UTC
Not a bug

The documented syntax does work

e.g:

request.body = ' 
{
  "action" : "set_current_group",
  "resource" : {
    "current_group" : { "description" : "EvmGroup-super_administrator" }
  }
}
'


Note You need to log in before you can comment on or make changes to this bug.