Bug 1733593 - The link to check for the prerequisite RHVM repositories in the 4.3 Upgrade Guide points to a 404 page
Summary: The link to check for the prerequisite RHVM repositories in the 4.3 Upgrade G...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation
Version: 4.3.6
Hardware: All
OS: All
unspecified
urgent
Target Milestone: ---
: ---
Assignee: rhev-docs@redhat.com
QA Contact: rhev-docs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-26 17:02 UTC by Greg Scott
Modified: 2019-07-26 19:17 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-26 19:17:04 UTC
oVirt Team: Docs
Target Upstream Version:


Attachments (Terms of Use)

Description Greg Scott 2019-07-26 17:02:01 UTC
Description of problem:
Go to section 4.1 of the Red Hat Virtualization 4.3 Upgrade Guide at https://access.redhat.com/documentation/en-us/red_hat_virtualization/4.3/html/upgrade_guide/upgrading_from_4-2#Upgrade_Prerequisites_4-2_local_db

Go to the bullet that says:

Ensure the Manager has the correct repositories enabled. For the list of required repositories, see Enabling the Red Hat Virtualization Manager Repositories for Red Hat Virtualization 4.2.

Click on the link and it goes to a 404 page.


Version-Release number of selected component (if applicable):
4.3


How reproducible:
At will

Steps to Reproduce:
1. See above
2.
3.

Actual results:
The link points to a 404 page.

Expected results:
The link should point to a good page. Or just list the prerequisite repositories right here, since links change all the time - and the risk of not updating a dead link is the same as listing the same information in more than one place.

Additional info:

This documentation bug turns out to be significant because there was a problem with the JBoss version during the 4.2 timeframe, and so anyone updgrading to the latest 4.2 z-stream as part of the 4.3 upgrade will first hit the documentation bug, and then engine-setup will blow up with a dependency error, probably because the user has the wrong Jboss channel. But the user has no way to find out what's going on because the documentation page that describes it is a 404.

Comment 1 Greg Scott 2019-07-26 19:17:04 UTC
The documentation team fixed it within a few minutes of reporting it - thanks! Since it's fixed, I'll close my own BZ.

- Greg


Note You need to log in before you can comment on or make changes to this bug.