Bug 1733602 - firewalld Requires kernel, which is no longer available on i686 in F31 and later.
Summary: firewalld Requires kernel, which is no longer available on i686 in F31 and la...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: firewalld
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: Eric Garver
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1728779 1734866 1735230
TreeView+ depends on / blocked
 
Reported: 2019-07-26 17:52 UTC by Justin M. Forbes
Modified: 2019-08-01 15:12 UTC (History)
3 users (show)

Fixed In Version: firewalld-0.7.1-2.fc31
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-01 15:12:17 UTC


Attachments (Terms of Use)

Description Justin M. Forbes 2019-07-26 17:52:16 UTC
Firewalld has a dependency on kernel.  This is understandable, but the kernel is no longer being built for i686 on F31 and newer. While I would recommend dropping the arch for firewalld on those releases as well, I suppose you could also drop the kernel Require.

Comment 1 Eric Garver 2019-07-30 20:39:11 UTC
(In reply to Justin M. Forbes from comment #0)
> Firewalld has a dependency on kernel.  This is understandable, but the
> kernel is no longer being built for i686 on F31 and newer. While I would
> recommend dropping the arch for firewalld on those releases as well, I
> suppose you could also drop the kernel Require.

How do I drop the arch?

Comment 2 Kaleb KEITHLEY 2019-07-31 16:58:25 UTC
Is it not sufficient to drop the "Requires: kernel ..." for i686 ?

Otherwise dropping the arch in firewalld just moves the problem, doesn't it? If you do that then in glusterfs I will have to drop the "Requires: firewalld" (which is probably not correct) or drop the arch as well.

Comment 3 Jason Tibbitts 2019-07-31 19:45:36 UTC
Why does firewalld require the kernel?  And why does it require a specific version of it?  It came in with commit cb592bb "rebase to v0.6.0" about a year ago, but I don't see why it was added.

If the idea is to ensure that the kernel be of at least a certain version, then even a simple Conflicts: kernel < 4.18.0 would suffice. It's possible that "Requires: (kernel >= 4.18.0 if kernel)" would also work if you really want to avoid Conflicts:, though I haven't tested it.  Or just drop the dependency in rawhide because, you know, the current F31 incarnation of rawhide hasn't ever had a kernel that old. That goes for F30 as well, though not F29 as it had 4.16 prereleases early in its cycle.

Comment 4 Eric Garver 2019-08-01 12:33:51 UTC
(In reply to Jason Tibbitts from comment #3)
> Why does firewalld require the kernel?  And why does it require a specific
> version of it?  It came in with commit cb592bb "rebase to v0.6.0" about a
> year ago, but I don't see why it was added.

v0.6.0 was dependent on features/fixes in the 4.18.0 kernel. At the time we were just after the transition to the 4.18 kernel.

> If the idea is to ensure that the kernel be of at least a certain version,
> then even a simple Conflicts: kernel < 4.18.0 would suffice. It's possible
> that "Requires: (kernel >= 4.18.0 if kernel)" would also work if you really
> want to avoid Conflicts:, though I haven't tested it.  Or just drop the
> dependency in rawhide because, you know, the current F31 incarnation of
> rawhide hasn't ever had a kernel that old. That goes for F30 as well, though
> not F29 as it had 4.16 prereleases early in its cycle.

I will drop the Requires in rawhide an f30.


Note You need to log in before you can comment on or make changes to this bug.