Bug 1733608 - RHOSP 15 Beta Standalone Installation Fails Due to Missing /usr/bin/python
Summary: RHOSP 15 Beta Standalone Installation Fails Due to Missing /usr/bin/python
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 15.0 (Stein)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ga
: 15.0 (Stein)
Assignee: Luke Short
QA Contact: Alexander Chuzhoy
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-26 18:30 UTC by Luke Short
Modified: 2019-09-27 10:44 UTC (History)
5 users (show)

Fixed In Version: openstack-tripleo-heat-templates-10.6.1-0.20190828180441.8dc2faf.el8ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-21 11:24:01 UTC
Target Upstream Version:


Attachments (Terms of Use)
Standalone deployment errors (19.02 KB, text/plain)
2019-07-26 18:30 UTC, Luke Short
no flags Details


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 673328 'None' 'MERGED' 'Move the Hiera symlink task from post configuration to deployment steps.' 2019-11-22 18:38:08 UTC
Red Hat Product Errata RHEA-2019:2811 None None None 2019-09-21 11:24:19 UTC

Description Luke Short 2019-07-26 18:30:08 UTC
Created attachment 1593774 [details]
Standalone deployment errors

Description of problem:
During one of the last few tasks of Step 5 of the deployment, it fails because Ansible cannot find a Python interpreter to use. Python is available at /usr/bin/python2, /urs/bin/python3, and /usr/libexec/platform-python. No package provide /usr/bin/python. I had to manually symlink /usr/bin/python3 to /usr/bin/python to get the installation to finish.

Version-Release number of selected component (if applicable):
RHOSP 15 Beta, RHEL 8.0, Ansible 2.8.2

How reproducible:
100%

Steps to Reproduce:
1. Follow the RHOSP 15 Beta Quickstart guide to install a standalone cloud. https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/15-beta/html/quick_start_guide/index
2. Use the RHOSP 15 Beta container registry
```
---
parameter_defaults:
  ContainerImagePrepare:
  - set:
      namespace: registry.redhat.io/rhosp-beta
      tag: 15.0
```

Actual results:
Ansible complains with this error:
"""
The following modules failed to execute: setup\\\\\\\\n  setup: The module failed to execute correctly, you probably need to set the interpreter.
"""

Expected results:
Deployment successful!

Additional info:
Ansible 2.8 *should* have automatically detected and found a Python interpreter on RHEL 8.

Packages installed:
```
$ rpm -qa | grep -P "ansible|tripleo"
ansible-2.8.2-1.el8ae.noarch
openstack-tripleo-puppet-elements-10.3.1-0.20190614132452.79c0c76.el8ost.noarch
ansible-role-chrony-0.0.1-0.20190423220429.494f3c4.el8ost.noarch
openstack-tripleo-heat-templates-10.6.1-0.20190713150434.2871ce0.el8ost.noarch
ansible-tripleo-ipsec-9.1.1-0.20190513190404.ffe104c.el8ost.noarch
openstack-tripleo-validations-10.4.1-0.20190701170405.10b4d77.el8ost.noarch
ansible-role-tripleo-modify-image-1.0.1-0.20190621160359.1415b04.el8ost.noarch
python3-tripleoclient-heat-installer-11.4.1-0.20190705110410.14ae053.el8ost.noarch
puppet-tripleo-10.4.2-0.20190701160408.ecbec17.el8ost.noarch
openstack-tripleo-image-elements-10.4.1-0.20190604170406.2c8a6a5.el8ost.noarch
ansible-role-container-registry-1.1.1-0.20190711170430.1217799.el8ost.noarch
python3-heat-agent-ansible-1.8.1-0.20190523210450.1e15344.el8ost.noarch
openstack-tripleo-common-10.8.1-0.20190710191707.b6a2d65.el8ost.noarch
python3-tripleoclient-11.4.1-0.20190705110410.14ae053.el8ost.noarch
python3-tripleo-common-10.8.1-0.20190710191707.b6a2d65.el8ost.noarch
ansible-role-redhat-subscription-1.0.4-0.20190701140422.fceb51c.el8ost.noarch
ansible-role-thales-hsm-0.2.1-0.20190422121359.9019dde.el8ost.noarch
openstack-tripleo-common-containers-10.8.1-0.20190710191707.b6a2d65.el8ost.noarch
ansible-pacemaker-1.0.4-0.20190418190349.0e4d7c0.el8ost.noarch
ansible-role-atos-hsm-0.1.1-0.20190422121159.1518dbd.el8ost.noarch
```

Comment 2 Alex Schultz 2019-07-29 14:54:33 UTC
In the undercloud[0] we actually set PythonInterpreter to sys.excutable. I think this is an issue with the rhel8 bits where we need to document that this be set for the undercloud

https://opendev.org/openstack/python-tripleoclient/src/branch/master/tripleoclient/v1/undercloud_config.py#L393

Comment 7 errata-xmlrpc 2019-09-21 11:24:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2019:2811


Note You need to log in before you can comment on or make changes to this bug.