Bug 1733696 - The autologin does not work
Summary: The autologin does not work
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: lightdm
Version: 30
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Alternative GTK desktop environments
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-27 12:55 UTC by sergiyvovk69
Modified: 2019-07-28 15:38 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-28 15:38:03 UTC


Attachments (Terms of Use)
lightdm configuration (6.84 KB, text/plain)
2019-07-27 12:55 UTC, sergiyvovk69
no flags Details
dnf history (7.99 KB, text/plain)
2019-07-28 10:40 UTC, sergiyvovk69
no flags Details

Description sergiyvovk69 2019-07-27 12:55:19 UTC
Created attachment 1593875 [details]
lightdm configuration

Description of problem:
After I updated the system the autologin does not work. When I turn the computer on I see the lightdm screen with password prompt.

For the autologin I specified
autologin-user=simple-user
in [Seat:*] section in /etc/lightdm/lightdm.conf file.
The simple-user is user name in system.

Version-Release number of selected component (if applicable):

How reproducible:
Always

Steps to Reproduce:
1. Install Fedora 30 with mate.
2. Configure the autologin.
3. Update system.

Actual results:
The autologin does not work.
When I turn the computer on I see the lightdm screen with password prompt.

Expected results:
When I turn the computer on the system must perform autologin to specified user.
The password must not be prompted.

Additional info:
# journalctl --no-pager -b -p err
Jul 27 16:14:42 localhost.localdomain kernel: sd 4:0:0:0: [sdc] No Caching mode page found
Jul 27 16:14:42 localhost.localdomain kernel: sd 4:0:0:0: [sdc] Assuming drive cache: write through
Jul 27 13:16:13 dhcppc3 wpa_supplicant[1066]: dbus: wpa_dbus_property_changed: no property SessionLength in object /fi/w1/wpa_supplicant1/Interfaces/0
Jul 27 13:16:17 localhost.localdomain dbus-broker-launch[1459]: Activation request for 'org.a11y.atspi.Registry' failed.
Jul 27 13:16:20 localhost.localdomain dbus-broker-launch[1459]: Activation request for 'org.a11y.atspi.Registry' failed.
Jul 27 13:16:30 localhost.localdomain lightdm[1562]: gkr-pam: unable to locate daemon control file

Comment 1 leigh scott 2019-07-27 16:13:32 UTC
Works fine here.

$lightdm --show-config
   [Seat:*]
B  allow-guest=false
E  session-wrapper=/etc/X11/xinit/Xsession
G  xserver-command=X -core -noreset
H  greeter-session=slick-greeter
I  autologin-user=leigh

   [LightDM]
C  minimum-vt=1
D  sessions-directory=/usr/share/xsessions
F  user-authority-in-system-dir=true

Sources:
A  /usr/share/lightdm/lightdm.conf.d/50-backup-logs.conf
B  /usr/share/lightdm/lightdm.conf.d/50-disable-guest.conf
C  /usr/share/lightdm/lightdm.conf.d/50-minimum-vt.conf
D  /usr/share/lightdm/lightdm.conf.d/50-remove-wayland-session.conf
E  /usr/share/lightdm/lightdm.conf.d/50-session-wrapper.conf
F  /usr/share/lightdm/lightdm.conf.d/50-user-authority-in-system-dir.conf
G  /usr/share/lightdm/lightdm.conf.d/50-xserver-command.conf
H  /usr/share/lightdm/lightdm.conf.d/90-slick-greeter.conf
I  /etc/lightdm/lightdm.conf



@raveit65 Can you confirm it works for you?

Comment 2 Wolfgang Ulbrich 2019-07-27 17:46:38 UTC
It works fine here with MATE session too.

 lightdm --show-config
   [Seat:*]
B  allow-guest=false
E  session-wrapper=/etc/X11/xinit/Xsession
G  xserver-command=X -core -noreset
H  greeter-session=slick-greeter
I  autologin-user=rave
I  greeter-show-manual-login=false

   [LightDM]
C  minimum-vt=1
D  sessions-directory=/usr/share/xsessions
F  user-authority-in-system-dir=true

Sources:
A  /usr/share/lightdm/lightdm.conf.d/50-backup-logs.conf
B  /usr/share/lightdm/lightdm.conf.d/50-disable-guest.conf
C  /usr/share/lightdm/lightdm.conf.d/50-minimum-vt.conf
D  /usr/share/lightdm/lightdm.conf.d/50-remove-wayland-session.conf
E  /usr/share/lightdm/lightdm.conf.d/50-session-wrapper.conf
F  /usr/share/lightdm/lightdm.conf.d/50-user-authority-in-system-dir.conf
G  /usr/share/lightdm/lightdm.conf.d/50-xserver-command.conf
H  /usr/share/lightdm/lightdm.conf.d/90-slick-greeter.conf
I  /etc/lightdm/lightdm.conf

Comment 3 Wolfgang Ulbrich 2019-07-27 17:55:59 UTC
Did you really power off the system (not suspending) after adding your user to lightdm.conf?
Which greeter frontend are you using?
slick-greeter or lightdm-gtk?

Comment 4 sergiyvovk69 2019-07-27 18:53:58 UTC
Usually I restart or power off computer. I never use the suspend function.
The greeter frontend is default: slick-greeter.
I don't change any other lightdm option except autologin-user.

My lightdm configuration:
$ lightdm --show-config
   [Seat:*]
B  allow-guest=false
E  session-wrapper=/etc/X11/xinit/Xsession
G  xserver-command=X -core -noreset
H  greeter-session=slick-greeter
I  autologin-user=simple-user

   [LightDM]
C  minimum-vt=1
D  sessions-directory=/usr/share/xsessions
F  user-authority-in-system-dir=true

Sources:
A  /usr/share/lightdm/lightdm.conf.d/50-backup-logs.conf
B  /usr/share/lightdm/lightdm.conf.d/50-disable-guest.conf
C  /usr/share/lightdm/lightdm.conf.d/50-minimum-vt.conf
D  /usr/share/lightdm/lightdm.conf.d/50-remove-wayland-session.conf
E  /usr/share/lightdm/lightdm.conf.d/50-session-wrapper.conf
F  /usr/share/lightdm/lightdm.conf.d/50-user-authority-in-system-dir.conf
G  /usr/share/lightdm/lightdm.conf.d/50-xserver-command.conf
H  /usr/share/lightdm/lightdm.conf.d/90-slick-greeter.conf
I  /etc/lightdm/lightdm.conf

Comment 5 Gerd Pokorra 2019-07-28 07:21:04 UTC
Would you please try what happens if you add the line

autologin-user-timeout=0

after the autologin-user=... line in /etc/ligthdm/lightdm.conf.

Comment 6 sergiyvovk69 2019-07-28 10:30:29 UTC
I had specified the
autologin-user-timeout=0
after the autologin-user=simple-user in /etc/ligthdm/lightdm.conf.
Then I restarted the computer.
And nothing changed. The problem was not fixed. I was still prompted a login/password.

------------

Now the lightdm config is the following:
$ lightdm --show-config
   [Seat:*]
B  allow-guest=false
E  session-wrapper=/etc/X11/xinit/Xsession
G  xserver-command=X -core -noreset
H  greeter-session=slick-greeter
I  autologin-user=simple-user
I  autologin-user-timeout=0

   [LightDM]
C  minimum-vt=1
D  sessions-directory=/usr/share/xsessions
F  user-authority-in-system-dir=true

Sources:
A  /usr/share/lightdm/lightdm.conf.d/50-backup-logs.conf
B  /usr/share/lightdm/lightdm.conf.d/50-disable-guest.conf
C  /usr/share/lightdm/lightdm.conf.d/50-minimum-vt.conf
D  /usr/share/lightdm/lightdm.conf.d/50-remove-wayland-session.conf
E  /usr/share/lightdm/lightdm.conf.d/50-session-wrapper.conf
F  /usr/share/lightdm/lightdm.conf.d/50-user-authority-in-system-dir.conf
G  /usr/share/lightdm/lightdm.conf.d/50-xserver-command.conf
H  /usr/share/lightdm/lightdm.conf.d/90-slick-greeter.conf
I  /etc/lightdm/lightdm.conf

-----------------

The "gkr-pam: unable to locate daemon control file" error still exists in the journal.
# journalctl --no-pager -b -u lightdm
Jul 28 12:46:34 localhost.localdomain systemd[1]: Starting Light Display Manager...
Jul 28 12:46:36 localhost.localdomain systemd[1]: Started Light Display Manager.
Jul 28 12:46:56 localhost.localdomain lightdm[1404]: pam_unix(lightdm-greeter:session): session opened for user lightdm by (uid=0)
Jul 28 12:47:33 localhost.localdomain lightdm[1558]: gkr-pam: unable to locate daemon control file
Jul 28 12:47:33 localhost.localdomain lightdm[1558]: pam_unix(lightdm:session): session opened for user simple-user by (uid=0)

Comment 7 sergiyvovk69 2019-07-28 10:38:15 UTC
After the Fedora setup I removed some unused programs.
Some depended packages was removed.
Maybe it is a reason. But it is unlikely.
I attached the dnf history.

Comment 8 sergiyvovk69 2019-07-28 10:40:39 UTC
Created attachment 1594010 [details]
dnf history

Comment 9 sergiyvovk69 2019-07-28 12:55:04 UTC
It's a wonder.
I tried
autologin-user-timeout=5
and the autologin works. Hooray!

The reason maybe related to the following. I installed Fedora to the external USB 2.0 hard drive. This hard drive is not fast.

Thank you very much for a great work!

Comment 10 Gerd Pokorra 2019-07-28 15:36:52 UTC
You are welcome. Thank you for the feedback. So I close the ticket.


Note You need to log in before you can comment on or make changes to this bug.