Bug 1733697 - [OSP15] controller replacement with LVM failed without proper explanation
Summary: [OSP15] controller replacement with LVM failed without proper explanation
Keywords:
Status: CLOSED DUPLICATE of bug 1737456
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: 15.0 (Stein)
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ga
: ---
Assignee: RHOS Maint
QA Contact: Sasha Smolyak
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-27 13:56 UTC by Artem Hrechanychenko
Modified: 2019-08-07 10:33 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-07 10:31:25 UTC
Target Upstream Version:


Attachments (Terms of Use)
ansible logs (5.15 MB, application/gzip)
2019-07-27 13:56 UTC, Artem Hrechanychenko
no flags Details

Description Artem Hrechanychenko 2019-07-27 13:56:45 UTC
Created attachment 1593876 [details]
ansible logs

Description of problem:
OSP15
3 controllers + 1 compute

Attempt to replace controller using beta documentation failed

PLAY [External deployment Post Deploy tasks] ***********************************

PLAY RECAP *********************************************************************
compute-0                  : ok=195  changed=54   unreachable=0    failed=0    skipped=737  rescued=0    ignored=2   
controller-0               : ok=214  changed=82   unreachable=0    failed=1    skipped=341  rescued=0    ignored=2   
controller-2               : ok=258  changed=94   unreachable=0    failed=0    skipped=674  rescued=0    ignored=2   
controller-3               : ok=212  changed=82   unreachable=0    failed=1    skipped=343  rescued=0    ignored=2   
undercloud                 : ok=11   changed=7    unreachable=0    failed=0    skipped=32   rescued=0    ignored=0   

Saturday 27 July 2019  09:38:35 -0400 (0:00:00.145)       1:19:37.843 ********* 
=============================================================================== 

Ansible failed, check log at /var/lib/mistral/overcloud/ansible.log.


from ansible.log I see only next failures:

controller-2

 "No systemd unit file was found for tripleo_cinder_volume_init_bundle.service",
        "No systemd unit file was found for tripleo_cinder_volume_init_bundle_healthcheck.service",
        "No systemd unit file was found for tripleo_cinder_volume_init_bundle_healthcheck.timer",
        "No systemd unit file was found for tripleo_cinder_volume_restart_bundle.service",
        "No systemd unit file was found for tripleo_cinder_volume_restart_bundle_healthcheck.service",
        "No systemd unit file was found for tripleo_cinder_volume_restart_bundle_healthcheck.timer",
        "stdout: Skipping execution since this is not the bootstrap node for this service.",

and nothing more

from pacemaker I didn't see than controller-3 was add 
[heat-admin@controller-0 ~]$ sudo pcs cluster status
Cluster Status:
 Stack: corosync
 Current DC: controller-0 (version 2.0.1-4.el8_0.3-0eb7991564) - partition with quorum
 Last updated: Sat Jul 27 13:53:00 2019
 Last change: Sat Jul 27 10:16:51 2019 by root via cibadmin on controller-0
 14 nodes configured
 49 resources configured

PCSD Status:
  controller-0: Online
  controller-2: Online



Version-Release number of selected component (if applicable):
RHOS_TRUNK-15.0-RHEL-8-20190722.n.1
python3-openstackclient-3.18.0-0.20190312140834.6868499.el8ost.noarch
openstack-tripleo-common-containers-10.8.1-0.20190719020421.f2a2fd2.el8ost.noarch
openstack-heat-monolith-12.0.1-0.20190704050403.bf16acc.el8ost.noarch
puppet-openstack_extras-14.4.1-0.20190420090934.6b1b687.el8ost.noarch
puppet-openstacklib-14.4.1-0.20190420125152.3719ca1.el8ost.noarch
openstack-tripleo-image-elements-10.4.1-0.20190705161217.2c8a6a5.el8ost.noarch
openstack-tripleo-validations-10.5.1-0.20190719021545.f3fe208.el8ost.noarch
openstack-heat-agents-1.8.1-0.20190523210450.1e15344.el8ost.noarch
openstack-heat-api-12.0.1-0.20190704050403.bf16acc.el8ost.noarch
openstack-tripleo-common-10.8.1-0.20190719020421.f2a2fd2.el8ost.noarch
openstack-selinux-0.8.19-0.20190606150404.06faac7.el8ost.noarch
python-openstackclient-lang-3.18.0-0.20190312140834.6868499.el8ost.noarch
openstack-tripleo-puppet-elements-10.3.2-0.20190710165331.c89fe3c.el8ost.noarch
openstack-heat-engine-12.0.1-0.20190704050403.bf16acc.el8ost.noarch
openstack-tripleo-heat-templates-10.6.1-0.20190722170519.014b20c.el8ost.noarch
python3-openstacksdk-0.27.0-0.20190405091843.4174082.el8ost.noarch
openstack-heat-common-12.0.1-0.20190704050403.bf16acc.el8ost.noarch


How reproducible:
always

Steps to Reproduce:
1.Deploy OSP15 with 3 controller
2.Try to replace controller-1 using official beta documentation and commands from bz#1722082 to cover invalid commands in beta documentation
3.

Actual results:


Expected results:


Additional info:
https://access.redhat.com/documentation/en-us/red_hat_openstack_platform/15-beta/
https://bugzilla.redhat.com/show_bug.cgi?id=1722082

Comment 6 Artem Hrechanychenko 2019-08-07 10:31:25 UTC

*** This bug has been marked as a duplicate of bug 1737456 ***


Note You need to log in before you can comment on or make changes to this bug.