Bug 17337 - color ls flashes with dead symlinks
color ls flashes with dead symlinks
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: fileutils (Show other bugs)
6.2
i386 Linux
low Severity low
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-09-07 17:57 EDT by Mike A. Harris
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-23 10:41:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike A. Harris 2000-09-07 17:57:01 EDT
The default color scheme with color ls has changed for some reason in
Red Hat 6.2.  The default color for dead symlinks is _flashing_ white on
a red background.  This is very hard on the eyes, especially when you
need to work in directories containing dead symlinks.  Since this is quite
annoying, I think the default for any colors used by "ls" should be 
non-flashing and also preferably with a black background.  Basically,
the way it was in Red Hat 6.1 and earlier.

After commenting about it on the zoot-list, I received back many private
comments from people in agreement.  I'll bet that the majority of users
will
not want their screen flashing over a simple little thing like a dead
symlink.

As such, I figured that I might as well request that it be changed back in
hopes that the gods above are listening.  ;o)
Comment 1 Need Real Name 2000-09-23 10:41:48 EDT
This is normal and can be edited in /etc/DIR_COLORS. I agree the colours for
broken links is not very comfortable.

ORPHAN 01;05;37;40  # orphaned syminks
MISSING 01;01;36;40 # ... and the files they point to

These are my colours now. Also flashing, but on a black background.
Comment 2 Bernhard Rosenkraenzer 2000-09-23 12:05:22 EDT
The general agreement here is that users should be made aware of problems -
including by flashing symlinks.
If you don't like it, edit /etc/DIR_COLORS or ~/.dircolors to turn it off.
See man dircolors for details.

Red Hat Linux 6.1 and earlier didn't do color ls, there's no way we're going
back to that.

Note You need to log in before you can comment on or make changes to this bug.