Bug 1733820 - GOG linux games will not run without "compatibility layer"
Summary: GOG linux games will not run without "compatibility layer"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gamehub
Version: 30
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Artem
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-28 23:24 UTC by James Hogarth
Modified: 2019-08-07 01:44 UTC (History)
1 user (show)

Fixed In Version: gamehub-0.14.2.1-3.fc30
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-07 01:44:32 UTC


Attachments (Terms of Use)
Disable gcc -O2 optimisation (982 bytes, patch)
2019-07-28 23:24 UTC, James Hogarth
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Github tkashkin GameHub issues 162 None None None 2019-07-28 23:24:27 UTC

Description James Hogarth 2019-07-28 23:24:27 UTC
Created attachment 1594119 [details]
Disable gcc -O2 optimisation

Description of problem:
The GOG linux games don't have a native run command, only a "run with compatibility layer" which then fails to launch the games.


How reproducible:
Known issue - see upstream bug linked.

This appears to be caused by having any build optimisation enabled.

Unfortunately '__global_compiler_flags' is hardcoded to -O2 and overrides any CFLAGS set manually to -O0.

This can be overridden by redefining the macro however.

I've run a quick test of the attached patch which ensures no optimisation is applied.

With this patch the games launch correctly.

Comment 1 Artem 2019-07-28 23:39:49 UTC
Yeah, i tested now and can reproduce this. The fun thing that i tested this in earlier builds and it works without this compatibility layer. Thank you for such informative bug report. Will try to test in now without -O2. You also suggesting bump to latest version in your patch, but i am not sure, maybe better staying on this first stable release:

https://github.com/tkashkin/GameHub/releases/tag/0.14.2-1-master

Comment 2 Fedora Update System 2019-07-29 00:40:43 UTC
FEDORA-2019-f0d066d230 has been submitted as an update to Fedora 30. https://bodhi.fedoraproject.org/updates/FEDORA-2019-f0d066d230

Comment 3 Fedora Update System 2019-07-30 00:56:05 UTC
gamehub-0.14.2.1-3.fc30 has been pushed to the Fedora 30 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2019-f0d066d230

Comment 4 Fedora Update System 2019-08-07 01:44:32 UTC
gamehub-0.14.2.1-3.fc30 has been pushed to the Fedora 30 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.