Bug 1733825 - Incorrect memory usage for openshift-monitoring namespace
Summary: Incorrect memory usage for openshift-monitoring namespace
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Monitoring
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.2.0
Assignee: Sergiusz Urbaniak
QA Contact: Viacheslav
URL:
Whiteboard:
: 1745654 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-29 01:38 UTC by Junqi Zhao
Modified: 2019-10-16 06:34 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:33:51 UTC
Target Upstream Version:


Attachments (Terms of Use)
Incorrect memory usage (109.84 KB, image/png)
2019-07-29 01:38 UTC, Junqi Zhao
no flags Details


Links
System ID Priority Status Summary Last Updated
Github kubernetes-monitoring kubernetes-mixin pull 243 None None None 2019-08-26 13:57:46 UTC
Github openshift cluster-monitoring-operator pull 454 None None None 2019-08-27 13:05:38 UTC
Github openshift cluster-monitoring-operator pull 456 None None None 2019-08-28 08:16:12 UTC
Red Hat Product Errata RHBA-2019:2922 None None None 2019-10-16 06:34:05 UTC

Description Junqi Zhao 2019-07-29 01:38:44 UTC
Created attachment 1594132 [details]
Incorrect memory usage

Description of problem:
Check memory usage for openshift-monitoring namespace in cluster console, it is only 66.09MB,
from the "Memory Usage by Pod (Top 10)" part, prometheus-k8s-0 already use 1.2GB.

it uses
namespace:container_memory_usage_bytes:sum{namespace='openshift-monitoring'}
to caculate the memory usage

search in prometheus, result is
**************************************
Element	Value
namespace:container_memory_usage_bytes:sum{label_name="prometheus-adapter",namespace="openshift-monitoring"}	66093056
namespace:container_memory_usage_bytes:sum{namespace="openshift-monitoring"}	2564440064
**************************************

Version-Release number of selected component (if applicable):
4.2.0-0.nightly-2019-07-28-222114

How reproducible:
Always

Steps to Reproduce:
1. See the description
2.
3.

Actual results:
Incorrect memory usage for openshift-monitoring namespace

Expected results:
correct memory usage for openshift-monitoring namespace

Additional info:

Comment 10 Sergiusz Urbaniak 2019-08-27 13:12:04 UTC
*** Bug 1745654 has been marked as a duplicate of this bug. ***

Comment 17 Viacheslav 2019-09-06 09:39:10 UTC
Still exist on build 4.2.0-0.nightly-2019-09-05-234433

Comment 18 Junqi Zhao 2019-09-09 01:51:18 UTC
fixed with 4.2.0-0.nightly-2019-09-08-180038

sum by(namespace) (container_memory_working_set_bytes{namespace="openshift-monitoring",container="",pod!=""})
Element	Value
{namespace="openshift-monitoring"}	2888843264

Comment 19 errata-xmlrpc 2019-10-16 06:33:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.