Bug 1733866 - pcp atop -w does not write process-level data in the archive
Summary: pcp atop -w does not write process-level data in the archive
Keywords:
Status: CLOSED DUPLICATE of bug 1723598
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: pcp
Version: ---
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: 8.0
Assignee: Nathan Scott
QA Contact: Jan Kurik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-29 05:39 UTC by Yogesh Babar
Modified: 2020-06-23 07:01 UTC (History)
5 users (show)

Fixed In Version: pcp-4.3.4
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-10 23:47:44 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)

Comment 1 Nathan Scott 2019-07-29 05:44:38 UTC
Looked into this with Yogesh on IRC today, looks like a logic error in the write-mode code causing hotproc metrics to be logged instead of proc.

Comment 2 Nathan Scott 2019-07-29 10:39:09 UTC
commit 165895bc5a287b9f3f2bf06519a3b5783632fefa
Author: Nathan Scott <nathans@redhat.com>
Date:   Mon Jul 29 20:38:17 2019 +1000

    pcp-atop: fix write mode (-w) handling of proc vs hotproc metrics
    
    This resolves Red Hat BZ #1733866.

Comment 3 Yogesh Babar 2019-07-30 01:25:57 UTC
(In reply to Nathan Scott from comment #2)
> commit 165895bc5a287b9f3f2bf06519a3b5783632fefa
> Author: Nathan Scott <nathans@redhat.com>
> Date:   Mon Jul 29 20:38:17 2019 +1000
> 
>     pcp-atop: fix write mode (-w) handling of proc vs hotproc metrics
>     
>     This resolves Red Hat BZ #1733866.

Wow thank was very quick. Thank you for fixing it so promptly. I hope it will be added as soon as possible in our rpm. 

Regards,
Ybabar

Comment 4 Nathan Scott 2019-10-10 23:47:44 UTC
This commit is part of the PCP rebase for 8.2 and does not require special QE team attention - marking it as a duplicate.

*** This bug has been marked as a duplicate of bug 1723598 ***

Comment 5 Yogesh Babar 2020-06-23 06:58:05 UTC
I acknowledge that the bug has been resolved in Fedora 32. It is working as per the expectation. Thank you Nathan and team.


Note You need to log in before you can comment on or make changes to this bug.