Bug 17339 - most of iso-8859-? not contain character cent
Summary: most of iso-8859-? not contain character cent
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: console-tools (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-09-07 23:22 UTC by Need Real Name
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-27 21:37:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-09-07 23:22:13 UTC
Please remove RH specific patch of
console-data-1999.08.29/keymaps/i386/include/qwert{y|z}-layout.inc
which add to these keymaps in include "euro" chars euro and cent.
Symbol cent is not a part of most iso-8859-? tables and composing
euro conflicts with some others e with accent chars.
Currently it is not possible to load keymaps which are based on these
partial keymaps and are not iso-8859-1 for ex. sk-*.kmap.

Comment 1 Bernhard Rosenkraenzer 2000-10-20 18:44:13 UTC
Looking into it...

Comment 2 Bernhard Rosenkraenzer 2000-10-20 19:11:19 UTC
Fixed in console-tools-0.3.3-29

Comment 3 Need Real Name 2000-10-27 21:37:01 UTC
There was removed only one of two bugs introduced by euro patch



Because sk* keymaps use AltGr_Lock to switch between two
alphabets there is by pressing key e generated symbol currency
instead of symbol e in second alphabet (I didn't checked others
keymaps).

If you really need symbols contained in euro.inc write directive
include "euro.inc" to all keymaps they know this symbols and
don't use AltGr_Lock (or tell me not using partial keymaps from
include directory and I will rewrite sk* keymaps).

Comment 4 Bernhard Rosenkraenzer 2001-01-17 13:59:09 UTC
Fixed in -31


Note You need to log in before you can comment on or make changes to this bug.