Bug 1733927 - fwupdmgr fails with SSL handshake failed
Summary: fwupdmgr fails with SSL handshake failed
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: fwupd
Version: 30
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-29 08:50 UTC by Nuno Dias
Modified: 2019-07-29 10:49 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-29 10:49:20 UTC


Attachments (Terms of Use)

Description Nuno Dias 2019-07-29 08:50:33 UTC
Description of problem:
Running

$ fwupdmgr refresh --verbose 

Fails with 
Failed to download https://cdn.fwupd.org/downloads/firmware.xml.gz: SSL handshake failed

Version-Release number of selected component (if applicable):
fwupd-1.2.10-1.fc30.i686

How reproducible:
Every time

Steps to Reproduce:
1. Run $ fwupdmgr refresh --verbose
2.
3.

Actual results:
Fail with the SSL handshake

Expected results:
No error

Additional info:
# fwupdmgr refresh --verbose
(fwupdmgr:7496): FuCommon-DEBUG: 09:48:41.171: creating path /root/.cache/fwupd
(fwupdmgr:7496): Fwupd-DEBUG: 09:48:41.171: looking for os-release at /etc/os-release
(fwupdmgr:7496): FuMain-DEBUG: 09:48:41.171: downloading https://cdn.fwupd.org/downloads/firmware.xml.gz to /root/.cache/fwupd/lvfs-metadata.xml.gz
Fetching metadata https://cdn.fwupd.org/downloads/firmware.xml.gz

(fwupdmgr:7496): GLib-GIO-CRITICAL **: 09:48:41.177: g_file_new_for_path: assertion 'path != NULL' failed
(fwupdmgr:7496): GLib-GIO-DEBUG: 09:48:41.177: _g_io_module_get_default: Found default implementation local (GLocalVfs) for ‘gio-vfs’
(fwupdmgr:7496): GLib-GIO-DEBUG: 09:48:41.177: _g_io_module_get_default: Found default implementation keyfile (GKeyfileSettingsBackend) for ‘gsettings-backend’
(fwupdmgr:7496): GLib-GIO-DEBUG: 09:48:41.178: _g_io_module_get_default: Found default implementation libproxy (GLibproxyResolver) for ‘gio-proxy-resolver’
(fwupdmgr:7496): GLib-GIO-DEBUG: 09:48:41.187: _g_io_module_get_default: Found default implementation gnutls (GTlsBackendGnutls) for ‘gio-tls-backend’

Failed to download https://cdn.fwupd.org/downloads/firmware.xml.gz: SSL handshake failed

Comment 1 Nuno Dias 2019-07-29 10:49:20 UTC
The problem was the i686 version installed instead of the x86_64 version.


Note You need to log in before you can comment on or make changes to this bug.