Bug 1733931 - Delete snapshot throws java.lang.NullPointerException in engine.log
Summary: Delete snapshot throws java.lang.NullPointerException in engine.log
Keywords:
Status: CLOSED DUPLICATE of bug 1727025
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: General
Version: 4.3.5.3
Hardware: x86_64
OS: Linux
unspecified
low vote
Target Milestone: ---
: ---
Assignee: Dana
QA Contact: Lukas Svaty
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-29 08:59 UTC by Ilan Zuckerman
Modified: 2019-08-05 11:15 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-08-05 11:15:49 UTC
oVirt Team: Infra


Attachments (Terms of Use)

Description Ilan Zuckerman 2019-07-29 08:59:11 UTC
Description of problem:
When deleting a snapshot, the following error is seen in engine log, although UI reports successful snapshot removal.

2019-07-29 08:35:49,519Z INFO  [org.ovirt.engine.core.bll.tasks.CommandAsyncTask] (EE-ManagedThreadFactory-engine-Thread-10) [] CommandAsyncTask::endCommandAction [within thread] context: Attempting to endAction 'DestroyImage',
2019-07-29 08:35:49,521Z ERROR [org.ovirt.engine.core.bll.tasks.CommandAsyncTask] (EE-ManagedThreadFactory-engine-Thread-10) [] [within thread]: endAction for action type DestroyImage threw an exception.: java.lang.NullPointerException
	at org.ovirt.engine.core.bll.tasks.CoCoAsyncTaskHelper.endAction(CoCoAsyncTaskHelper.java:358) [bll.jar:]
	at org.ovirt.engine.core.bll.tasks.CommandCoordinatorImpl.endAction(CommandCoordinatorImpl.java:348) [bll.jar:]
	at org.ovirt.engine.core.bll.tasks.CommandAsyncTask.endCommandAction(CommandAsyncTask.java:150) [bll.jar:]
	at org.ovirt.engine.core.bll.tasks.CommandAsyncTask.lambda$endActionIfNecessary$0(CommandAsyncTask.java:103) [bll.jar:]
	at org.ovirt.engine.core.utils.threadpool.ThreadPoolUtil$InternalWrapperRunnable.run(ThreadPoolUtil.java:96) [utils.jar:]
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [rt.jar:1.8.0_222-ea]
	at java.util.concurrent.FutureTask.run(FutureTask.java:266) [rt.jar:1.8.0_222-ea]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [rt.jar:1.8.0_222-ea]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [rt.jar:1.8.0_222-ea]
	at java.lang.Thread.run(Thread.java:748) [rt.jar:1.8.0_222-ea]
	at org.glassfish.enterprise.concurrent.ManagedThreadFactoryImpl$ManagedThread.run(ManagedThreadFactoryImpl.java:250) [javax.enterprise.concurrent.jar:1.0.0.redhat-1]

Version-Release number of selected component (if applicable):
ovirt-engine-4.3.5.3-0.1.el7.noarch
rhv-release-4.3.5-5-001.noarch
vdsm-4.30.19-1.el7ev.x86_64

How reproducible:
100

Steps to Reproduce:
1. Create a Snapshot out of running vm
2. Delete the created snapshot while the vm is running


Actual results:
The snapshot is removed according the UI, but engine log shows java.lang.NullPointerException when removing it.

Expected results:
No errors should be seen in the log

Additional info:
Full engine log is can be found in the private message below.

Comment 2 Dana 2019-08-05 11:15:49 UTC

*** This bug has been marked as a duplicate of bug 1727025 ***


Note You need to log in before you can comment on or make changes to this bug.