Bug 1733938 - postfix doesn't support LDAP SASL
Summary: postfix doesn't support LDAP SASL
Keywords:
Status: VERIFIED
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: postfix
Version: 7.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jaroslav Škarvada
QA Contact: Patrik Moško
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-29 09:29 UTC by Jaroslav Škarvada
Modified: 2019-10-15 14:54 UTC (History)
2 users (show)

Fixed In Version: postfix-2.10.1-9.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed:
Target Upstream Version:


Attachments (Terms of Use)

Description Jaroslav Škarvada 2019-07-29 09:29:50 UTC
Description of problem:
LDAP SASL support is not enabled in postfix.

Version-Release number of selected component (if applicable):
postfix-2.10.1-7.el7

How reproducible:
Always

Steps to Reproduce:
1. set bind = sasl in LDAP custom alias_maps
2.
3.

Actual results:
postalias: fatal: /etc/postfix/ldap-aliases.cf: unsupported parameter value: bind = sasl

Expected results:
No error

Additional info:
Fix is to recompile postfix with the LDAP SASL support -DUSE_LDAP_SASL

Comment 2 Jaroslav Škarvada 2019-07-29 09:35:52 UTC
It has been already fixed in Fedora bug 1052958.


Note You need to log in before you can comment on or make changes to this bug.