Bug 1733981 - SELinux is preventing systemd-user-ru from 'mount' accesses on the filesystem /.
Summary: SELinux is preventing systemd-user-ru from 'mount' accesses on the filesystem /.
Keywords:
Status: CLOSED DUPLICATE of bug 1733845
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 30
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:abec8a75900a70da919ddcf2589...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-29 11:43 UTC by mb272936
Modified: 2019-07-29 12:27 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-29 12:27:32 UTC


Attachments (Terms of Use)

Description mb272936 2019-07-29 11:43:03 UTC
Description of problem:
SELinux is preventing systemd-user-ru from 'mount' accesses on the filesystem /.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that systemd-user-ru should be allowed mount access on the  filesystem by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'systemd-user-ru' --raw | audit2allow -M my-systemduserru
# semodule -X 300 -i my-systemduserru.pp

Additional Information:
Source Context                system_u:system_r:systemd_logind_t:s0
Target Context                system_u:object_r:usr_t:s0
Target Objects                / [ filesystem ]
Source                        systemd-user-ru
Source Path                   systemd-user-ru
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           filesystem-3.10-1.fc30.x86_64
Policy RPM                    selinux-policy-3.14.3-42.fc30.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 5.1.18-300.fc30.x86_64 #1 SMP Mon
                              Jul 15 15:42:34 UTC 2019 x86_64 x86_64
Alert Count                   1
First Seen                    2019-07-29 03:32:10 EDT
Last Seen                     2019-07-29 03:32:10 EDT
Local ID                      a5765047-b785-4ff2-85da-519394f47c77

Raw Audit Messages
type=AVC msg=audit(1564385530.29:665): avc:  denied  { mount } for  pid=19001 comm="systemd-user-ru" name="/" dev="tmpfs" ino=478694 scontext=system_u:system_r:systemd_logind_t:s0 tcontext=system_u:object_r:usr_t:s0 tclass=filesystem permissive=0


Hash: systemd-user-ru,systemd_logind_t,usr_t,filesystem,mount

Version-Release number of selected component:
selinux-policy-3.14.3-42.fc30.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.10.1
hashmarkername: setroubleshoot
kernel:         5.1.18-300.fc30.x86_64
type:           libreport

Comment 1 Lukas Vrabec 2019-07-29 12:27:32 UTC

*** This bug has been marked as a duplicate of bug 1733845 ***


Note You need to log in before you can comment on or make changes to this bug.