Bug 1734009 - [3.11 backport] Synchronization firewall rules takes up to 90min
Summary: [3.11 backport] Synchronization firewall rules takes up to 90min
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: ---
: 3.11.z
Assignee: Casey Callendrello
QA Contact: zhaozhanqi
URL:
Whiteboard:
: 1590589 1712494 (view as bug list)
Depends On: 1699341
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-29 12:41 UTC by Casey Callendrello
Modified: 2019-10-02 09:26 UTC (History)
20 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The unidling proxy caused iptables lock contention with the service proxy. Consequence: Clusters with large numbers of services and unidled services could see long times in applying endpoint changes to cluster ips. Fix: Access to iptables is better coordinated.
Clone Of: 1699341
Environment:
Last Closed: 2019-09-24 08:08:08 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift origin pull 23426 'None' closed Bug 1734009: Unidling: minimize iptables lock contention 2020-02-05 07:38:11 UTC
Red Hat Product Errata RHBA-2019:2816 None None None 2019-09-24 08:08:18 UTC

Comment 1 Ryan Howe 2019-07-31 16:47:37 UTC
This is the Origin 3.11 backport I do believe:   https://github.com/openshift/origin/pull/23426

Comment 15 errata-xmlrpc 2019-09-24 08:08:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2816

Comment 16 Ryan Howe 2019-09-26 20:31:57 UTC
*** Bug 1590589 has been marked as a duplicate of this bug. ***

Comment 17 Ryan Howe 2019-09-26 20:32:22 UTC
*** Bug 1712494 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.