Bug 173402 - app-defaults/XTerm should be treated as configuration file
app-defaults/XTerm should be treated as configuration file
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xterm (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-16 18:07 EST by Gilles Detillieux
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-16 21:19:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gilles Detillieux 2005-11-16 18:07:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050810 Red Hat/1.7.10-0.90.1.legacy

Description of problem:
Updates to the xterm package clobber local customizations to the /usr/X11R6/lib/X11/app-defaults/XTerm file.  We need to run a custom version of this file because a few things in the default file included in FC4 (e.g. use of UTF-8 fonts) conflicts with the Starnet X-Win32 package we use for remote access to the Linux servers.  When the xterm package is updated automatically via nightly yum runs, these changes are lost and X-Win32 can't start xterm on the updated servers.

If this file were flagged as %config in the %files section of the .spec file, then at best the yum update would leave the local configuration alone and save the new configuration as an XTerm.rpmnew file, and and worst it would save the local configuration as an XTerm.rpmsave file and warn me that it has done so.

Version-Release number of selected component (if applicable):
xterm-205-1.FC4

How reproducible:
Always

Steps to Reproduce:
1. Downgrade to xterm-200-6.
2. Edit /usr/X11R6/lib/X11/app-defaults/XTerm to remove utf-8 stuff.
3. Run "yum update".
  

Actual Results:  /usr/X11R6/lib/X11/app-defaults/XTerm customizations were lost.

Expected Results:  New configuration stored as /usr/X11R6/lib/X11/app-defaults/XTerm.rpmnew or custom configuration saved as /usr/X11R6/lib/X11/app-defaults/XTerm.rpmsave, and yum should have said what it was doing to that file.

Additional info:

This problem isn't unique to FC4 either, but this was the latest occurrence of it.  It has happened in the past when xterm was updated in older Fedora Core releases.
Comment 1 Mike A. Harris 2005-11-16 21:19:53 EST
The supplied app-defaults files are not intended to be used as local
configuration files, and they often get modified to fix various bugs.
If they were marked as config files, the bug fixes would not get applied
to systems which have modified these files.  In some cases, the fixes
have been security in nature.

Local customizations to resource settings should be done via ~/.Xresources
or via systemwide configuration in /etc.

Comment 2 Gilles Detillieux 2005-11-17 15:25:01 EST
What files in /etc can I change to override font definitions, menu definitions, and key translations 
from the app-defaults/XTerm file, and have them applied to an xterm application launched via 
rexec, and displaying on a remote, MS-Windows based X11 server?  We're not using xinit or xdm, 
or any Linux-based window manager in the loop at all, so the usual approaches using either /etc/
X11/Xresources or ~/.Xresources won't work for us.  I stopped trying to use ~/.Xdefaults a long 
time ago because it was a pain to maintain all these files in several user directories.  I also read 
recently in another bugzilla bug report for xterm (comment #7 in bug #160354) that ~/.Xdefaults 
is no longer used by xterm, so that doesn't seem to be a viable option either.

Note You need to log in before you can comment on or make changes to this bug.