Bug 1734103 - A garbage in scl-utils RPM package change log
Summary: A garbage in scl-utils RPM package change log
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: scl-utils
Version: 8.1
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: 8.0
Assignee: Pavlina Moravcova Varekova
QA Contact: Lukáš Zachar
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-29 15:52 UTC by Petr Pisar
Modified: 2019-11-05 20:58 UTC (History)
2 users (show)

Fixed In Version: scl-utils-2.0.2-10.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-05 20:58:38 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:3388 None None None 2019-11-05 20:58:42 UTC

Description Petr Pisar 2019-07-29 15:52:07 UTC
scl-utils-2.0.2-9.el8.x86_64 contains a garbage in its changelog:

# rpm -q --changelog scl-utils | head
* Tue Jul 02 2019 Pavlina Moravcova Varekova <pmoravco@redhat.com> - 1:2.0.2-9
- use .el8 instead of .el8 (#1725774)
- scl-utils-build own the pkgconfig directory by 
%defattr(-,root,root,-)
%dir %_scl_prefix
%dir %attr(555,root,root) %{_scl_root}
%dir %attr(555,root,root) %{_scl_scripts}
%{_scl_scripts}/enable
%{_root_sysconfdir}/scl/prefixes/%scl
%{_scl_root}/bin

That's caused by an unescaped per-cent character in the spec file:

%changelog
* Tue Jul 02 2019 Pavlina Moravcova Varekova <pmoravco@redhat.com> - 1:2.0.2-9
- use %{?dist} instead of %{dist} (#1725774)
- scl-utils-build own the pkgconfig directory by %scl_files (#1431962)
                                                 ^^^^^^^^^^
* Wed May 22 2019 Pavlina Moravcova Varekova <pmoravco@redhat.com> - 1:2.0.2-8
- Own directory /etc/scl (#1616405)

Comment 1 Petr Pisar 2019-07-30 05:55:43 UTC
scl-utils-2.0.2-8.el8 was fine. This is a regression.

Comment 5 errata-xmlrpc 2019-11-05 20:58:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3388


Note You need to log in before you can comment on or make changes to this bug.