Bug 1734148 - [Azure IPI] e2e-azure fails on: users can manipulate groups [Suite:openshift/conformance/parallel] test
Summary: [Azure IPI] e2e-azure fails on: users can manipulate groups [Suite:openshift/...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Auth
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.2.0
Assignee: Stefan Schimanski
QA Contact: scheng
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-29 18:30 UTC by Yu Qi Zhang
Modified: 2019-10-16 06:34 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:33:52 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift origin pull 23531 None None None 2019-08-01 08:21:00 UTC
Red Hat Product Errata RHBA-2019:2922 None None None 2019-10-16 06:34:02 UTC

Description Yu Qi Zhang 2019-07-29 18:30:45 UTC
Description of problem:

Openshift e2e-azure tests consistently fails on:

[Feature:UserAPI] users can manipulate groups [Suite:openshift/conformance/parallel]

fail [github.com/openshift/origin/test/extended/user/basic.go:63]: expected [system:authenticated system:authenticated:oauth], got [system:authenticated system:authenticated:oauth theGroup-e2e-test-user-api-dmr8v]

See: e.g. https://prow.svc.ci.openshift.org/view/gcs/origin-ci-test/pr-logs/pull/openshift_installer/2098/pull-ci-openshift-installer-master-e2e-azure/91

Version-Release number of selected component (if applicable):
Openshift 4.2

How reproducible:
Always

Steps to Reproduce:
See any log in: https://prow.svc.ci.openshift.org/pr-history/?org=openshift&repo=installer&pr=2098

Actual results:
Test fails

Expected results:
Test passes

Additional info:

Comment 2 Kirsten Garrison 2019-07-31 19:53:59 UTC
Failure was also seen in local testing in the PR that added these tests: https://github.com/openshift/origin/pull/23279#issuecomment-506011099

Comment 3 Stefan Schimanski 2019-08-01 08:21:51 UTC
Fixed in https://github.com/openshift/origin/pull/23531

Comment 6 errata-xmlrpc 2019-10-16 06:33:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.