Bug 1734204 - Anaconda crash when installing to 256 GB NVMe drive
Summary: Anaconda crash when installing to 256 GB NVMe drive
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 29
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-30 01:14 UTC by Jeffrey Walton
Modified: 2019-07-31 13:34 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-31 13:34:23 UTC


Attachments (Terms of Use)
Anaconda and storage error (114.19 KB, image/png)
2019-07-30 01:14 UTC, Jeffrey Walton
no flags Details
Anaconda and crash on NVMe drive (274.96 KB, image/png)
2019-07-30 01:15 UTC, Jeffrey Walton
no flags Details

Description Jeffrey Walton 2019-07-30 01:14:10 UTC
Created attachment 1594436 [details]
Anaconda and storage error

I purchased a new Dell XPS 8930 (https://www.amazon.com/gp/product/B078N85NCR). It comes with a 256 GB NVMe drive, and a 2 TB 7200 RPM SATA drive. Under Windows there was some sort of RAID going on.

I'm trying to install F29 on the 256 GB NVMe drive. I select the drive, and the drive shows with the check mark and blue highlight. The second drive is unchecked. Everything looks OK.

When I click "Done" the drive becomes unchecked and a yellow error banner is displayed at the bottom of the Window. The banner says, "Error checking storage configuration". See installer1.png.

When is use 'dd' to zero out the first 1 GB of the NVMe drive, then Anaconda crashes when attempting to install the operating system. See installer2.png.

I'm getting ready to remove the NVMe drive, and install a mSATA SSD instead. But it would be nice if I could use the machine in a factory configuration.

-----

The eventual intention is, install the OS on the NVMe drive. Then, move /opt, /var and swap to the SATA drive. Finally, fill the SATA drive with virtual machines for testing.

This is my second attempt at installing Fedora on this machine. The first time I checked both disks. The problem was, Fedora ran awful slow because everything was installed on the SATA drive. The machine and mouse had jitters like I was working on an old Pentium II machine, and not a Core 17-8700 with 64 GB of RAM.

Comment 1 Jeffrey Walton 2019-07-30 01:15:05 UTC
Created attachment 1594437 [details]
Anaconda and crash on NVMe drive

Comment 2 Jeffrey Walton 2019-07-30 01:38:24 UTC
Also see https://bugzilla.redhat.com/show_bug.cgi?id=1734207. Issue 1734207 is the other half of this bug report. The 1734207 report is the Anaconda back trace submitted through the crash reporter.

Comment 3 Jeffrey Walton 2019-07-30 01:54:40 UTC
This report may be a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1650190.

Comment 4 Vendula Poncova 2019-07-30 07:57:25 UTC
Please, attach files /tmp/*log with Anaconda logs from the crash.

Comment 5 Jeffrey Walton 2019-07-31 09:13:42 UTC
(In reply to Vendula Poncova from comment #4)
> Please, attach files /tmp/*log with Anaconda logs from the crash.

Thanks Vendula.

It appears the issue was fixed in Fedora 30. OK to close.


Note You need to log in before you can comment on or make changes to this bug.