Bug 1734218 - Missing lua-devel package
Summary: Missing lua-devel package
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: lua
Version: 8.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: 8.0
Assignee: Packaging Maintenance Team
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-30 02:07 UTC by Luke Short
Modified: 2020-10-20 16:17 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-10-20 16:17:57 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)

Description Luke Short 2019-07-30 02:07:06 UTC
Description of problem:
RHEL 8 ships with a `lua` package but not a related `lua-devel` package. This makes compiling programs against lua impossible without manually downloading and copying over source files to the appropriate locations.

Version-Release number of selected component (if applicable):
RHEL 8.0

How reproducible:
100%

Steps to Reproduce:
1. sudo subscription-manager repos --enable=rhel-8-for-x86_64-baseos-rpms --enable=rhel-8-for-x86_64-appstream-rpms
2. sudo yum search lua-devel

Actual results:
```
$ sudo yum install lua-devel
Updating Subscription Management repositories.
Red Hat Enterprise Linux 8 for x86_64 - AppStream (RPMs)                                                                                                                                                      3.2 kB/s | 4.5 kB     00:01    
Red Hat Enterprise Linux 8 for x86_64 - BaseOS (RPMs)                                                                                                                                                         2.8 kB/s | 4.0 kB     00:01    
No match for argument: lua-devel
Error: Unable to find a match
$ sudo yum whatprovides lua.h
Updating Subscription Management repositories.
Last metadata expiration check: 0:00:51 ago on Mon 29 Jul 2019 09:59:51 PM EDT.
Error: No Matches found
```

Expected results:
There should be a package for lua-devel that can be installed. All versions of Fedora ship lua-devel and so does RHEL 7.

Additional info:
According to this documentation [1], lua-devel is no longer a package in RHEL 8 (but lua is). I am not sure why this package would be dropped. The source code for the RPM spec file shows that there is still logic for building a devel package for RHEL/CentOS 8 [2].

1. https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/8/html-single/considerations_in_adopting_rhel_8/index
2. https://git.centos.org/rpms/lua/blob/c8/f/SPECS/lua.spec#_61

Comment 4 Daniel Mach 2019-11-14 10:13:55 UTC
The lua-devel package wasn't included in the distro because the RPM team doesn't want to support it.
There is currently no business justification to release it.

If there's the business justification, please reopen the bug.

Comment 5 ccorley@us.ibm.com 2020-08-04 22:39:22 UTC
I need lua_devel to port a C++ program to registry.access.redhat.com/ubi8/ubi:latest.  Instead, I either need to download lua_devel myself or build my image on another platform.

Comment 9 Kyle Walker 2020-10-14 12:39:35 UTC
The lua-devel package is actually in the Codeready Builder repository already.

    $ sudo yum search lua-devel --showduplicates --disablerepo=\* --enablerepo=codeready-builder-for-rhel-8-x86_64-rpms
    Updating Subscription Management repositories.
    Last metadata expiration check: 2:13:14 ago on Wed 14 Oct 2020 06:23:30 AM EDT.
    ==================================== Name Exactly Matched: lua-devel ====================================
    lua-devel-5.3.4-10.el8.x86_64 : Development files for lua
    lua-devel-5.3.4-10.el8.i686 : Development files for lua
    lua-devel-5.3.4-11.el8.x86_64 : Development files for lua
    lua-devel-5.3.4-11.el8.i686 : Development files for lua

With that being the case, it should only be necessary to add the following to allow access to the package:

    $ sudo subscription-manager repos --enable codeready-builder-for-rhel-8-x86_64-rpms

For more information regarding the CRB repository, please see the following:

    Chapter 3. The CodeReady Linux Builder repository Red Hat Enterprise Linux 8 | Red Hat Customer Portal
    https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/8/html/package_manifest/codereadylinuxbuilder-repository

    Introducing CodeReady Linux Builder - Red Hat Developer
    https://developers.redhat.com/blog/2018/11/15/introducing-codeready-linux-builder/


@lshort@redhat.com,
Does that provide the need indicated?

Comment 10 Luke Short 2020-10-20 16:04:18 UTC
This should work for my needs. Thanks for the workaround!

Comment 11 Luke Short 2020-10-20 16:11:15 UTC
Kyle also helped me find a lua-devel package in CentOS 8 as well:

http://packages.oit.ncsu.edu/centos/8/PowerTools/x86_64/os/Packages/lua-devel-5.3.4-11.el8.x86_64.rpm

We can close this BugZilla.

Comment 12 Luke Short 2020-10-20 16:11:16 UTC
Kyle also helped me find a lua-devel package in CentOS 8 as well:

http://packages.oit.ncsu.edu/centos/8/PowerTools/x86_64/os/Packages/lua-devel-5.3.4-11.el8.x86_64.rpm

We can close this BugZilla.

Comment 13 Kyle Walker 2020-10-20 16:17:57 UTC
Per the previous update, closing this as CURRENTRELEASE!


Note You need to log in before you can comment on or make changes to this bug.