Bug 1734291 - No build status when run `oc get builds --watch`
Summary: No build status when run `oc get builds --watch`
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 4.4.0
Assignee: Maciej Szulik
QA Contact: wewang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-30 07:50 UTC by Wenjing Zheng
Modified: 2020-05-13 21:51 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2020-05-13 21:51:57 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:0581 0 None None None 2020-05-13 21:51:58 UTC

Description Wenjing Zheng 2019-07-30 07:50:33 UTC
Description of problem:
No build status like before when run below command which cannot reveal whether build completes or not:
$ oc get builds -n wzheng1 --watch
NAME                    AGE
django-psql-example-1   5m36s
django-psql-example-1   6m5s
django-psql-example-1   6m6s
django-psql-example-1   6m6s


Version-Release number of selected component (if applicable):
$ oc version
Client Version: version.Info{Major:"4", Minor:"2+", GitVersion:"v4.2.0", GitCommit:"2e9d4a117", GitTreeState:"clean", BuildDate:"2019-07-28T17:15:26Z", GoVersion:"go1.12.6", Compiler:"gc", Platform:"linux/amd64"}
Server Version: version.Info{Major:"1", Minor:"14+", GitVersion:"v1.14.0+1682e38", GitCommit:"1682e38", GitTreeState:"clean", BuildDate:"2019-07-28T20:08:40Z", GoVersion:"go1.12.6", Compiler:"gc", Platform:"linux/amd64"}


How reproducible:
Always

Steps to Reproduce:
1.No build status when user try to watch whether build completes or not
$ oc get builds -n wzheng1 --watch
2.
3.

Actual results:
No build status.

Expected results:
Should at least add STATUS column when watch build status.

Additional info:

Comment 2 Maciej Szulik 2020-03-13 15:30:07 UTC
This was fixed in between, moving to qa for verification.

Comment 5 wewang 2020-04-22 08:58:28 UTC
Verified in version:
$ oc version 
Client Version: 4.4.0-202003051431-2576e48
Server Version: 4.4.0-0.nightly-2020-04-21-210658
Kubernetes Version: v1.17.1

[wewang@wangwen work]$ oc get builds --watch
NAME        TYPE     FROM          STATUS    STARTED          DURATION
ruby-ex-1   Source   Git@c00ecd7   Running   56 seconds ago   
ruby-ex-1   Source   Git@c00ecd7   Running   59 seconds ago   
ruby-ex-1   Source   Git@c00ecd7   Running   59 seconds ago   
ruby-ex-1   Source   Git@c00ecd7   Complete   59 seconds ago   59s

Comment 7 errata-xmlrpc 2020-05-13 21:51:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:0581


Note You need to log in before you can comment on or make changes to this bug.