Bug 1734346 - [downstream clone - 4.3.6] warning on update of rhv-openvswitch
Summary: [downstream clone - 4.3.6] warning on update of rhv-openvswitch
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: rhv-openvswitch
Version: 2.1.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ovirt-4.3.6
: ---
Assignee: Miguel Duarte Barroso
QA Contact: Michael Burman
URL:
Whiteboard:
Depends On: 1717056
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-30 10:02 UTC by RHV bug bot
Modified: 2019-10-10 15:36 UTC (History)
7 users (show)

Fixed In Version: rhv-openvswitch-2.11-5
Doc Type: Bug Fix
Doc Text:
Previously, backticks inside the bash 'test' command caused errors to be logged when the bash script was interpreted. The current release fixes this issue by using $() and quoting the output.
Clone Of: 1717056
Environment:
Last Closed: 2019-10-10 15:36:44 UTC
oVirt Team: Network
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:3008 0 None None None 2019-10-10 15:36:45 UTC

Description RHV bug bot 2019-07-30 10:02:47 UTC
+++ This bug is a downstream clone. The original bug is: +++
+++   bug 1717056 +++
======================================================================

Created attachment 1577180 [details]
terminal log

Description of problem:
yum reports
Failed to get unit file state for ovn-northd.service: No such file or directory
/var/tmp/rpm-tmp.5P3a0a: line 5: [: =: unary operator expected
Failed to get unit file state for ovirt-provider-ovn.service: No such file or directory
/var/tmp/rpm-tmp.5P3a0a: line 5: [: =: unary operator expected


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. update rhv-openvswitch on host
2.
3.

Actual results:
warning is shown

Expected results:
no warning is shown

Additional info:
rhv-openvswitch              noarch 1:2.10-6.el7ev

(Originally by Dominik Holler)

Comment 1 RHV bug bot 2019-07-30 10:02:49 UTC
error message on clean install on rhvm:
Failed to get unit file state for openvswitch.service: No such file or directory
/var/tmp/rpm-tmp.ap2vYM: line 5: [: =: unary operator expected
Failed to get unit file state for ovn-northd.service: No such file or directory
/var/tmp/rpm-tmp.ap2vYM: line 5: [: =: unary operator expected
Failed to get unit file state for ovirt-provider-ovn.service: No such file or directory
/var/tmp/rpm-tmp.ap2vYM: line 5: [: =: unary operator expected
Failed to get unit file state for ovn-controller.service: No such file or directory
/var/tmp/rpm-tmp.ap2vYM: line 5: [: =: unary operator expected

(Originally by Dominik Holler)

Comment 2 RHV bug bot 2019-07-30 10:02:51 UTC
Let us just remove the "/var/tmp/rpm-tmp.ap2vYM: line 5: [: =: unary operator expected" and keep the "Failed to get unit file state for openvswitch.service: No such file or directory"

(Originally by Dominik Holler)

Comment 3 RHV bug bot 2019-07-30 10:02:52 UTC
FWIW, I get the same messages when installing rhv-openvswitch-1:2.11-4.el8ev.

(Originally by Milan Zamazal)

Comment 6 RHV bug bot 2019-07-30 10:02:57 UTC
(In reply to Miguel Duarte Barroso from comment #4)
> Created attachment 1582600 [details]
> double quote all the variables
> 
> Dominik, do you mind checking if this patch addresses this issue ?

Yes, looks good, thanks for the fix!
Can you push this to rhv-openvswitch/refs/rhevm-4.4-* ?

(Originally by Dominik Holler)

Comment 7 RHV bug bot 2019-07-30 10:02:59 UTC
Ouch, a bash-bigginer's bug of mine.

(Originally by danken)

Comment 8 RHV bug bot 2019-07-30 10:03:00 UTC
*** Bug 1725018 has been marked as a duplicate of this bug. ***

(Originally by Dominik Holler)

Comment 14 Michael Burman 2019-08-05 10:44:36 UTC
Verified on rhv-openvswitch-2.11-5.el7ev.noarch.rpm

Comment 15 Rolfe Dlugy-Hegwer 2019-09-18 19:44:21 UTC
I have updated the contents of the Doc Text field as follows:
"Previously, backticks were used inside the bash 'test' command. This caused errors to be logged when the bash script was interpreted. The current release fixes this issue by using $() and quoting the output."

If needed, please update the Doc Text or notify me immediately.

Comment 17 errata-xmlrpc 2019-10-10 15:36:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3008


Note You need to log in before you can comment on or make changes to this bug.