Bug 1734360 - When vdsm spice CA file checking may fail if spice ca directory don't exists
Summary: When vdsm spice CA file checking may fail if spice ca directory don't exists
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: ovirt-host-deploy-ansible
Version: future
Hardware: Unspecified
OS: Unspecified
unspecified
low vote
Target Milestone: ovirt-4.3.6
: 4.3.6.1
Assignee: Ondra Machacek
QA Contact: Pavol Brilla
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-30 10:59 UTC by Ondra Machacek
Modified: 2019-09-26 19:43 UTC (History)
2 users (show)

Fixed In Version: ovirt-engine-4.3.6.1
Doc Type: No Doc Update
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-09-26 19:43:34 UTC
oVirt Team: Infra
pm-rhel: ovirt-4.3+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 102257 ovirt-engine-4.3 MERGED enroll-cert: Check spice directory exists 2019-07-31 07:49:14 UTC
oVirt gerrit 102296 ovirt-engine-4.3 MERGED enroll-cert: Check spice directory exists 2019-08-04 10:54:03 UTC

Description Ondra Machacek 2019-07-30 10:59:42 UTC
Description of problem:
https://github.com/oVirt/ovirt-engine/blob/825a709e765cb1b7f3a72fcb4804edd74207f497/packaging/playbooks/roles/ovirt-host-enroll-certificate/tasks/vdsm.yml#L7

If the spice ca directory don't exist the task above fails.

Version-Release number of selected component (if applicable):
ovirt-engine-4.3

How reproducible:
always

Steps to Reproduce:
1. Make sure the ca directory don't exist and run enroll certificate command.

Actual results:
fail

Expected results:
succeed

Additional info:

Comment 1 Pavol Brilla 2019-09-10 11:23:02 UTC
host_mixed_3# mv libvirt-spice libvirt-spice2

Enroll certificate from engine:
Sep 10, 2019, 1:18:03 PM Enrolling certificate for host host_mixed_3 was completed successfully (User: admin@internal-authz).
Sep 10, 2019, 1:17:20 PM Enrolling certificate for host host_mixed_3 was started (User: admin@internal-authz).


# yum list ovirt-engine
Installed Packages
ovirt-engine.noarch                                      4.3.6.5-0.1.el7

Comment 2 Sandro Bonazzola 2019-09-26 19:43:34 UTC
This bugzilla is included in oVirt 4.3.6 release, published on September 26th 2019.

Since the problem described in this bug report should be
resolved in oVirt 4.3.6 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.