Bug 1734364 - Y-axis value crosses the graph border in Query Browser
Summary: Y-axis value crosses the graph border in Query Browser
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Management Console
Version: 4.2.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 4.2.0
Assignee: Andrew Pickering
QA Contact: Viacheslav
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-30 11:15 UTC by Junqi Zhao
Modified: 2019-10-16 06:34 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-16 06:34:08 UTC
Target Upstream Version:


Attachments (Terms of Use)
text crosses the graph border (84.78 KB, image/png)
2019-07-30 11:15 UTC, Junqi Zhao
no flags Details
not overlapping now (81.44 KB, image/png)
2019-08-07 03:24 UTC, Junqi Zhao
no flags Details
overlapping for some other value (70.34 KB, image/png)
2019-08-13 02:53 UTC, Junqi Zhao
no flags Details
graph from prometheus, it uses unit "T" (63.05 KB, image/png)
2019-08-13 02:56 UTC, Junqi Zhao
no flags Details


Links
System ID Priority Status Summary Last Updated
Github openshift console pull 2256 None None None 2019-08-05 05:31:35 UTC
Github openshift console pull 2494 None None None 2019-08-27 09:23:39 UTC
Red Hat Product Errata RHBA-2019:2922 None None None 2019-10-16 06:34:20 UTC

Description Junqi Zhao 2019-07-30 11:15:52 UTC
Created attachment 1594582 [details]
text crosses the graph border

Description of problem:
Search following metric in Query Browser
time() - (sum(kubeproxy_sync_proxy_rules_last_timestamp_seconds) / :kube_pod_info_node_count:) > 90

see the attached picture, text crosses the graph border 

Version-Release number of selected component (if applicable):
4.2.0-0.nightly-2019-07-28-222114

How reproducible:
For big values

Steps to Reproduce:
1. See the description
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Junqi Zhao 2019-08-07 03:24:19 UTC
Created attachment 1601226 [details]
not overlapping now

Comment 3 Junqi Zhao 2019-08-07 03:25:18 UTC
4.2.0-0.nightly-2019-08-05-223032
the text is not overlapping now

Comment 4 Junqi Zhao 2019-08-13 02:53:27 UTC
Created attachment 1603128 [details]
overlapping for some other value

eg; 200,000 b

Comment 6 Junqi Zhao 2019-08-13 02:56:45 UTC
Created attachment 1603129 [details]
graph from prometheus, it uses unit "T"

Comment 8 Viacheslav 2019-08-29 13:26:13 UTC
Fixed.

4.2.0-0.nightly-2019-08-28-235925

Comment 9 errata-xmlrpc 2019-10-16 06:34:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2922


Note You need to log in before you can comment on or make changes to this bug.