Bug 1734383 - [NMCI] reloading wireguard kernel module makes NetworkManager crash
Summary: [NMCI] reloading wireguard kernel module makes NetworkManager crash
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: NetworkManager
Version: 8.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.0
Assignee: sushil kulkarni
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-07-30 12:04 UTC by Filip Pokryvka
Modified: 2020-11-14 07:07 UTC (History)
8 users (show)

Fixed In Version: NetworkManager-1.20.0-1.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-11-05 22:30:06 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)
NM log (386.09 KB, text/plain)
2019-07-30 12:30 UTC, Filip Pokryvka
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:3623 0 None None None 2019-11-05 22:30:18 UTC

Description Filip Pokryvka 2019-07-30 12:04:51 UTC
Description of problem:
reloading wireguard kernel module before running NMCI test wireguard_activate_connection makes NM crash. The crash happens after step:
  * Add a new connection of type "wireguard" and options "ifname nm-wireguard con-name wireguard wireguard.private-key qOdhat/redhat/redhat/redhat/redhat/redhatUE= wireguard.listen-port 23456 ipv4.method manual ipv4.addresses 172.25.17.1/24 "

Version-Release number of selected component (if applicable):
NetworkManager-1.20.0-0.4.el8

How reproducible:
always

Steps to Reproduce:
# compile the kernel module, test will pass
 nmcli/runtest.sh wireguard_activate_connnection
# reload wireguard kernel module
 modprobe -r wireguard; sleep 1; modprobe wireguard 
# run test again - NM crash after the first step
 nmcli/runtest.sh wireguard_activate_connnection

Actual results:
NM crashes

Expected results:
NM should survive module reload

Additional info:
No crash in older version 1.20.0-0.3.el8

Comment 1 Filip Pokryvka 2019-07-30 12:30:57 UTC
Created attachment 1594603 [details]
NM log

Comment 3 Thomas Haller 2019-07-31 08:46:11 UTC
Fixed upstream.

Will be at lastest fixed by 1.20.0 release.

Comment 6 errata-xmlrpc 2019-11-05 22:30:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3623


Note You need to log in before you can comment on or make changes to this bug.