Bug 173439 - radeon driver crashes with "modular"
radeon driver crashes with "modular"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks: FC5Blocker
  Show dependency treegraph
 
Reported: 2005-11-16 21:54 EST by Michal Jaegermann
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-05 12:15:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
failure to start log (27.14 KB, text/plain)
2005-11-16 21:54 EST, Michal Jaegermann
no flags Details

  None (edit)
Description Michal Jaegermann 2005-11-16 21:54:19 EST
Description of problem:

.....
Fatal server error:
Caught signal 11.  Server aborting

Comparing old log from 6.8.2 with the one for 6.99.99.902 this happens
more or less around a monitor detection.  A sample log from a failed
attempt is attached

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.5.6.1-1
Comment 1 Michal Jaegermann 2005-11-16 21:54:19 EST
Created attachment 121157 [details]
failure to start log
Comment 2 Mike A. Harris 2005-11-22 22:30:06 EST
Thanks for the report.  To help ensure this problem gets investigated in
time for X11R7, please file a bug report in X.Org bugzilla located at
http://bugs.freedesktop.org in the "xorg" component.  Attach your X server
log and config file to the X.Org report, and flag the bug as blocking bug
#1690 - the release blocker bug.  This will ensure the issue gets reviewed
before X11R7 is released.

Once your report is filed with X.Org, if you paste the URL to the bug here,
Red Hat will track the issue in X.Org bugzilla and review any patches that
become available for consideration in future Fedora development builds.

Thanks in advance.


Setting status to "NEEDINFO_REPORTER", and awaiting upstream bug URL
reference for tracking.
Comment 3 Michal Jaegermann 2005-11-23 02:41:38 EST
All right. https://bugs.freedesktop.org/show_bug.cgi?id=5133
Comment 4 Michal Jaegermann 2005-11-30 02:15:40 EST
The same bug was already fixed for 6.8.2 here:
https://bugs.freedesktop.org/show_bug.cgi?id=4859
and resurfaced again in with 6.99.99.902.  The patch is obvious if one knows
that 'xf86InterpretEDID()' function is really allowed to return NULL.
Comment 5 Mike A. Harris 2005-11-30 04:18:22 EST
Cool, thanks.  I'm planning on updating to RC3 as soon as it is released,
which is supposed to be tomorrow if it hits the X.Org schedule.

Looks like ajax checked it into CVS, so it should be in the RC3 server.  I'll
update the bug once I've got the new X server built in rawhide.
Comment 6 Mike A. Harris 2006-02-05 12:15:30 EST
Fedora development has the X11R7.0 final release of xorg-x11-server-Xorg 1.0.1
present now.  Please upgrade to the latest packages.

Note You need to log in before you can comment on or make changes to this bug.