This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 173441 - RFE: pre-populate yum's repodata cache for active repos as part of install
RFE: pre-populate yum's repodata cache for active repos as part of install
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
: FutureFeature
: 173442 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-11-16 22:32 EST by Jef Spaleta
Modified: 2009-02-16 15:31 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-16 15:31:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jef Spaleta 2005-11-16 22:32:11 EST
Description of problem:
as dicussed in #fedora-devel
the idea is to pre-populate repodata on disk so things like yum provides
or repoquery runs can be done against the local cache after ststen install
regardless of network state. This recovers some of the usefulness that
fedora-rpmdb allowed to run dependancy/provides queries.

Clearly, for fc5 it would be good enough to pre-populate just base. Though it
would be great to be able to pre-populate whatever repos are active at install
time in future releases.
Comment 1 Rahul Sundaram 2005-11-17 08:07:36 EST
*** Bug 173442 has been marked as a duplicate of this bug. ***
Comment 2 Red Hat Bugzilla 2007-06-11 23:00:20 EDT
requested by Jams Antill
Comment 3 Jeremy Katz 2008-05-28 15:54:35 EDT
We actually do this for the media case now.  It might make sense to do in more
cases depending on how Chris's work turns out
Comment 4 Chris Lumens 2008-08-27 17:06:29 EDT
I've committed a potential fix here that should keep repodata for all FTP/HTTP repos that get enabled.  This will be in the next build of anaconda.  Let me know if it works and we can close this one out for real.

Note You need to log in before you can comment on or make changes to this bug.